Smart Quotes Not...

I’m working on a manuscript. Last night all was right with the world, smart quotes were doing their magic. This morning, suddenly any new quotes I type are straight. It’s more of an inconvenience than much else, a bit jarring having seen smart quotes being all smarty. Any way for me to get it back to where they’re smarting again?

Three quick tests:

  1. If you select a bunch of text that has straight quotes and use the Format/Convert/Quotes to Smart Quotes menu command, do they convert?
  2. Do you have ‘Use smart quotes (“ ”)’ checked off in the Corrections preference pane?
  3. How well is the smart quote feature working in the Apple utility, TextEdit?

I’m having the same problem. Smart quotes in Scrivener 2.3.1 have stopped working for me.

Answers to your tests:

  1. If I convert to smart quotes manually using Format/Convert, it works, but not by normal typing

  2. I have smart quotes selected in preferences.

  3. Smart quotes in Text Edit work fine also.

I’ve restarted my Mac, and also Scrivener, and it hasn’t helped. It would be a lot of work to manually select every section and manually convert (and to remember to do so after making new edits). Any suggestions/help would be greatly appreciated. If anyone else is having this problem, please chime in.

Thank you!

  1. Yes, it converts, which is why I’m not crying
  2. Preferences > Corrections > Substitutions: “Use smart quote” is checked. In fact, all substitutions except “Superordinal numbers” is checked.
  3. Smart quotes not working in TextEdit. I went to TextEdit > Preferences > New Document > Options “Smart Quotes” was not checked. I checked it, then re-tested. Does not work.

OS: 10.8.2.

Sorry for the somewhat pregnant pause between first post and follow-up.

While you’re figuring out the real solution, perhaps an easier way to periodically fix the quotes is to select the Manuscript folder, and click on the scrivenings mode, then select all the text (click into the editor, then CMD-A) and do the Format->Convert->Quotes to Smart Quotes. That at least should be less tedious than clicking on all the individual documents.

Actually the reason for asking whether it converts is that the conversion tool uses OS X’s typography engine to set the quotes, so if that did not work, it would indicate that the problem is in your OS X type settings. Since it does work, that’s not the problem.

Are you using the latest version of Scrivener? There was a bug in earlier versions, and 10.7+ that would sometimes cause spell check and correction substitution to fail sporadically. The latest version, 2.3.x has fixed this problem, so if you are seeing a lower number in the About Scrivener box, please try upgrading before any other troubleshooting.

It was a good thought, to make sure Text Edit was properly converting quotes to smart quotes. I remember corresponding with the author of Scrivener years ago, and he mentioned that Scrivener uses core OS X services. It’s curious that Text Edit is converting the quotes properly, but Scrivener isn’t (anymore, as it used to, very recently even … seems to be a project-level glitch, as now that it has stopped working, it hasn’t converted them automatically for a few days).

As far as versions, I’m using Scrivener 2.3.1, which is the latest available via the Check update in app. My Mac OS X version is 10.7.5.

@robertdguthrie thank you for the tip!

Go to and download the latest from there … 2.3.5. Don’t worry that it says “beta” … it’s just as stable as the release version on the website and has many bug-fixes, including the one that is hitting you, and enhancements.


2.3.1 has the bug fix for this particular problem. Incidentally it was related to how 10.7+ attempts to restore the state of a window. This was conflicting, if I recall correctly, with Scrivener’s own state persistence code and causing projects to lose spell check while typing and auto-correction. So TextEdit would still work under this bug, and hacking Lion’s hidden preferences to exclude Scrivener from the state restore system was a workaround until the software was fixed. However this isn’t your problem, as you have the patched version already. You could install the beta if you like, but I don’t think it will solve this particular matter.

Another thing that comes to mind is scriptwriting mode. Script formats rarely want font typography, and so by default these features are disabled in scriptwriting mode. Are you icons yellowish with a 3-hole punch on the left side? If you need scriptwriting mode, there is an option in the Corrections pane that will disable this override. Otherwise you might want to toggle the document back to standard writing mode with Cmd-8.

Will check out the beta version, thanks. (If this beta goes “live” anytime in the near future, I may just wait for that, because I’m not a beta version type person.)

I’m using a novel template, not scriptwriting. The smart quotes worked for a time into my project, I think, then stopped.

To be clear, you can absolutely have a scriptwriting document in a project that started life being spawned from a novel template. The software is quite flexible like that, very intentionally to make writing treatments easier. Having script formatted text and narrative text side-by-side is valuable. So the only way to know for sure if your document is actually a script file is to check its icon, and to look at the footer bar in the editor. If the footer bar has no word/character count and has a menu with element types in it, it’s a script document and won’t have typographic corrections.

OK, good to know. Thanks.

I don’t believe I haver script formatted text. I see in the footer: Page 1 of 2 (Words: 540 Chars: 3,071)

Hmm, okay that’s not the problem then if you have those stats. I’m running out of ideas for what can cause this. If you make a new blank project on your Desktop or somewhere temporary, does typography fail there as well?


Thank you for your continued help.

When starting a new document, the smart quotes work. I do believe they worked when my current project began, and stopped working some point along the way.

Additionally, spell check no longer works as I type (in my current project), which I think confirms something you said about a prior bug, “related to how 10.7+ attempts to restore the state of a window.” You said the problem was fixed by the Scrivener release I’m using, 2.3.1, but perhaps not?

Anyway, I wonder if you’ve identified the problem, “with Scrivener’s own state persistence code and causing projects to lose spell check while typing and auto-correction.” I’m using Mac OS X 10.7.5.

The only question is, if I am indeed facing this holdover bug, is it fixed in a Scrivener version later than 2.3.1, or is there another remedy?

That certainly does sound like the bug in question. I’m mistaken in that the 2.3.1 version has this fix in place. If you don’t mind trying a beta version (you can run it without un-installing the stable version) please view this forum thread and give 2.3.5 a try. Our betas are pretty stable, as they largely just represent bug fixes over the current stable version.

Thanks again. Any idea when this beta will be released as a download update? (Or more generally, is there a 3-6 month period of time between releases, or is it monthly, or …)

There isn’t any kind of formal schedule, no. It usually tends to be in the 3–6 month bracket though. This release in particular is due out pretty soon as there are some important bug fixes in it.

Sorry for taking so long to reply. You can see how infrequent my writing bouts have been lately. Installed Scriv 2.3.5 (and yes, your betas are very stable). Problem resolved.

I was having the same problem and this worked for me too. Thanks!