[SOLVED] Comments Keyboard Shortcut

I’ve tried a search for this, but nothing’s coming up.

I just started working with the Scrivener 3 Beta and it’s great. I’m looking forward to purchasing an upgrade when it’s released.

When I try to use the keyboard shortcut to add a comment (Shift + F4), the font formatting window opens instead (F4).

I’m on a Thinkpad T440s, and they’ve combined their function keys with controls for microphones, volume, etc. So I have to use Shift + Fn + F4. This works in other programs without trouble, but not in Scrivener 3. Is this a known bug?

It would be best to post this in the beta discussion forum: http://www.literatureandlatte.com/forum/viewforum.php?f=57.

Moderator Note: moved to the beta testing board.

Shift-F4 works here. However.

File → Options (or F12) → Keyboard

Filter for comment

Select Comment under Format.

Underneath should appear the key combination.

Try –
Click Record (to the right) of the key combination box, and record your key combo. Click Apply, see if anything changed. I see nothing different with Fn, but I don’t have a Thinkpad. If it does show something different, the devs would like to know, I think.

I suspect it’s a bug, perhaps in the underlying QT library for reading the keyboard.

However, another option is here: forums.lenovo.com/t5/ThinkPad-T … -p/1422663

FN + Esc should undo the FN key requirement.

Still, Scrivener should properly recognize the key combination, because supposedly the processor is handing it the proper keycode.

You’re a lifesaver, @rwfranz - thank you! I think I figured out what’s going wrong.

For the developers: no bug to be reported. There’s a problem with my external keyboard that I’ve been able to replicate in other programs now that I’m aware of it.

Thanks for the follow-up!