[SOLVED] Images disappear when Scrivener closes

Hey, folks!

I posted this here before, long ago, but I believe the issue hasn’t been addressed yet.

Essentially, Scrivener won’t save any of the pictures I attach to the project. I may simply copy them and paste them to Scrivener, or import them using Insert > Image from file. Once I close Scrivener, then open it again, the image is gone.

The issue should be easy to reproduce. I tried to do this with at least 3 different versions of the beta, to the same effect.

I’d appreciate any feedback on this :smiley:

I use loads of images in my writing and I’ve never had a problem with Scrivener failing to save them and always in the correct place in the text. In particular, I never had this problem with any of the betas or RC versions either.

I just left-click on the images in explorer and slide them across to a folder in the research folder in the binder. Sometimes I slide over multiple images at same time. It also works with Insert > image from file or copy and paste.

From the research folder, I select and drag each image into the text where it should go. Scrivener saves the file with all the images without any special effort.

Hey, Phil!

Thank you so much for your reply! I finally managed to import a picture to Scrivener, but it will still disappear when added to text.

Have you tried dragging an image straight from the Explorer to text? Does that work for you? It seems a little counterintuitive that the program would allow me to do that, display the image, only to delete it when I close it.

Here’s a video to better illustrate the problem:


Thanks for your help! :smiley:

Could you please upload the original image that you try to import. Thanks!

Your project is also stored on OneDrive at the moment. Could you please try the same having your project stored on your Desktop.

I certainly have. Again no problem. Maybe tiho can find something in your image file? Although I note in your video that it is a .png which is the format I habitually use.

My projects are stored on Dropbox.

Thank you Tiho and Phil for your help! OneDrive does seem to be the issue, as moving to project to my desktop seems to have solved it. I would never have guessed it!