[SOLVED] Scivener Unusable?

My writing Macbook runs on Catalina 10.15.7, Scrivener was working perfectly until a week or two ago. I started to get the “Scrivener quit unexpectedly,” message with the problem details. Scrivener would open after that and I could work on whatever project. I open it today and I get that message with the same details, but it doesn’t open from the app or a project. I’ve tried uninstalling and reinstalling it, I tried installing an older version, I’ve tried moving the plist file and opening it from the terminal. I’ve also tried opening it in safe mode. Nothing is working now. I don’t understand how it thinks whatever I try to download is a ???/bootleg version. lol I bought and downloaded it from the main website!

Process: Scrivener [853]
Path: /Applications/Scrivener.app/Contents/MacOS/Scrivener
Identifier: com.literatureandlatte.scrivener3
Version: ???
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Scrivener [853]
User ID: 502

Date/Time: 2021-04-06 17:07:08.662 -0600
OS Version: Mac OS X 10.15.7 (19H2)
Report Version: 12
Anonymous UUID: 762E654A-0D12-F7E8-9B29-96650EAA6695

Time Awake Since Boot: 2500 seconds

System Integrity Protection: disabled

Crashed Thread: 0

Exception Type: EXC_CRASH (Code Signature Invalid)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Termination Reason: Namespace CODESIGNING, Code 0x1

kernel messages:

VM Regions Near 0 (cr2):

__TEXT 0000000109859000-0000000109f31000 [ 7008K] r-x/r-x SM=COW

Thread 0 Crashed:
0 @,E 0x000000010f05d000 _dyld_start + 0

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x0000000000000000 rbx: 0x0000000000000000 rcx: 0x0000000000000000 rdx: 0x0000000000000000
rdi: 0x0000000000000000 rsi: 0x0000000000000000 rbp: 0x0000000000000000 rsp: 0x00007ffee63a6bf8
r8: 0x0000000000000000 r9: 0x0000000000000000 r10: 0x0000000000000000 r11: 0x0000000000000000
r12: 0x0000000000000000 r13: 0x0000000000000000 r14: 0x0000000000000000 r15: 0x0000000000000000
rip: 0x000000010f05d000 rfl: 0x0000000000000200 cr2: 0x0000000000000000

Logical CPU: 0
Error Code: 0x00000000
Trap Number: 0

Binary Images:
0x109859000 - 0x109f30127 +@,E (0) <51B5C8B3-2578-3640-B872-A6E2F88B5C03> @,E
0x10f05c000 - 0x10f0edf47 +@,E (750.6) <1D318D60-C9B0-3511-BE9C-82AFD2EF930D> @,E

External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 1371
thread_create: 0
thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=8140K resident=0K(0%) swapped_out_or_unallocated=8140K(100%)
Writable regions: Total=8420K written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=8420K(100%)

                            VIRTUAL   REGION 

REGION TYPE SIZE COUNT (non-coalesced)
=========== ======= =======
Stack 8192K 1
__DATA 1464K 4
__TEXT 7592K 2
shared memory 8K 2
=========== ======= =======
TOTAL 73.4M 14

Unable to gather system configuration information.Model: MacBook7,1, BootROM MB71.003F.B00, 2 processors, Intel Core 2 Duo, 2.4 GHz, 8 GB, SMC 1.60f5
Graphics: kHW_NVidiaGeForce320MItem, NVIDIA GeForce 320M, 256 MB
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1067 MHz, 0x80CE, 0x4D34373142353137335148302D594B302020
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1067 MHz, 0x85F7, 0x483634353155363446373036364700000000
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x93), Broadcom BCM43xx 1.0 (
Bluetooth: Version 7.0.6f7, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: WDC WD10JUCT-63CYNY0, 1 TB
Serial ATA Device: HL-DT-ST DVDRW GS23N
USB Device: USB 2.0 Bus
USB Device: USB 2.0 Bus
USB Device: Built-in iSight
USB Device: USB Bus
USB Device: USB Bus
USB Device: BRCM2070 Hub
USB Device: Bluetooth USB Host Controller
USB Device: Apple Internal Keyboard / Trackpad
Thunderbolt Bus:

This is a known issue involving the SentinelOne security package. Please make sure you have the most current version of that software. More information here: scrivener.tenderapp.com/help/kb … ning-error


Not to be a butt… This Mac doesn’t have SentinelOne so the issue you’ve described is not applicable to this situation. Thanks anyway. The other solution on the linked page was already tried as well, Scrivener was not recognizing the older versions. A time machine backup also didn’t fix this issue. The only “extra” program that has been added to this device is Scrivener, because this is my writing laptop.

Mac OS: Catalina 10.15.7
Device: MacBook “Core 2 Duo” 2.26 13-Inch (White Polycarbonate “Unibody”)
Device Year: Late 2009
Memory: 8GB
Storage: 1Terabyte
Free Storage: 961.4GB
Metal Compatible Chip: No
Big Sur Compatible: No

Note this device is what is sometimes referred to as an “unsupported” device. The device is still compatible with Catalina, so this is not a factor, anything that runs on Catalina normally will run on this device so long as you have the storage and horsepower.

If someone else encounters this random issue where Scrivener just decides to stop working on a whim and you don’t have SentinelOne on your machine this might be a solution.

Go to launchpad > [type disk utility] > open disk utility > run first aid on each drive your Mac has > shutdown do not restart > hold the option key or command + r as soon as you boot it back up > select the disk you normally use to work off of > Scrivener will be reset note you may have to re-enter your license

IF your Mac is not able to use the command + r combo having a spare external hard rive plugged in and hitting the option key immediately after powering up can sometimes help. You can try selecting your normal disk, OR you can click to the top to try to get the hidden menu to show so you can either redownload your OS. I would make this your last ditch attempt to fix the issue. Be sure to have you files backed up onto a couple of devices/places.

Yes, it is an unsupported device and according to Apple not compatible with Catalina. While you may get Catalina to work, Apple do not guarantee or support Catalina on that model. Results could be erratic and could have unintended consequences.

It’s a bit difficult for L&L to support your Scrivener on that device when Apple will not recommend, nor support the OS you are using on it.

MacBook 7,1 should be mid 2010 from memory. Max supported RAM 4gb, Yosemite, latest supported OS.

You say ‘Scrivener just decides to stop working on a whim’ (very unlikely) then describe a drive repair process. Perhaps the drive screwed up Scrivener, especially in your case where you are running the OS on unsupported hardware.

The “crash” you experienced indicates a code signing error. Quite a number of things can cause that, the Sentinel One situation came about because of how that software would inject itself into other running programs and essentially change how they work. The Mac saw that as a viral intrusion and instantly stomped on the process.

There are other things that could cause code signing issues, like a corrupted installation, bad certificates on the device, etc. It’s interesting that drive format failures were the cause of it in this case, I wouldn’t have thought of that as a potential culprit, but I suppose I can see how in theory it might lead to such problems (perhaps leading back around to a corrupted install being the final result, but from a corrupted filesystem).

I described it as a “whim” as a portion of apple enthusiasts who like the “retro” hardware (we mod iPod Classics, etc) are not always tech savvy or from the get go, Sometimes there’s a learning curve to modding hardware and software for older technology, so I was trying to keep the verbiage accessible/understandable vs Nick Burnsing it. I suppose the “keeping things simple mindset” comes from the nursing program I’m in. The disk repair and that grey landing screen are a weird catch-all fixes for a variety of issues, it’s kind of like restarting a pc for a random bug and having it magically work after, when restarting shouldn’t have had an impact. I’ve managed SQL servers and had some of the weirdest/most uncommon issues pop up and had the fix be a bit of a head-scratcher like this.

I also listed my specs for users who may have modded their system in a similar way I did to try to help provide a solution that is easier to search for (or so I hope) in Google since the forum’s search function isn’t always helpful. I don’t want to discourage users and have them turn around and demand a refund, or complain to their credit company for a refund (this can hurt Literature & Latte as a company). I’ve actually seen a few other forums where people site the L&L forum as being unhelpful with the latest Macs and the given generic fixes for issues that have been around since the early versions of the Mac OS version. It’s why I don’t like to post here before trying everything I can think of several times (for several hours). I switched from my 2019 Macbook to this older device, because I got tired of consistently running into things, and so far this was the only real issue I’ve had with my dinosaur.

Thanks for everyone keeping an eye on this and jumping in to help.

Just to be clear, running Mac Scrivener on hardware that Apple doesn’t support is entirely at your own risk. We’ll do our best to help, but in the end we don’t have control over your hardware.

To the general point, “generic” advice turns out to help an enormous number of people. That’s why it’s the first response. But when generic advice doesn’t work because the user has a non-standard configuration that they hadn’t previously mentioned, we’re happy to pursue more detailed troubleshooting.


Could the phrase “on Catalina 10.15.7 ?” be added to the title of this post. Less worrisome for those of us using contemporary equipment/software for important projects!