Something weird happening with the strikethrough weight

I first noticed it because I was using font Candara and regardless of line or line height, it is very hard to see the strikethrough.
I found it looked normal when I used the Segoe UI font.
I made a new document, used Segoe UI, and saw this:

They all have the same font name, size, and weight. They weren’t written in the shown order, meaning line 3 was written before line 2. When line 3 was on line 2, it was thin. After pressing Enter on the end of line 1 again, it thickened up.

I created a new project and am having the same results.

This is Candara size 14. Three words are struckout

And spellcheck warnings could be more noticeable.

This is Segoe UI, Candara, Arial

I can just barely notice the two outer ones on the page, but Candara I can only see with my face inches from the screen and I would have to know where to look.
I didn’t see an option to change color or weight

Also, with the strikethrough, it behaves appropriately when compiled (to pdf).

Options / Appearance / Textual Marks / Spell Check Underline
But you can only change the color.

The underline type is set in Options / Corrections / Spelling

Check to see if you’ve got the OS overriding Scrivener’s settings if it wants to spellcheck too… (An hypothesis.)

. . . . . . .

As for the strikethrough, check the display settings / font hinting, halfway down the Options / Editing / Options panel.

Else it could be your screen settings in the OS, perhaps some lines falling in the odd inbetween or something… If you’ve set it to a not-so-functional %

If you move a strike-through word that is off down a line without touching it (add a carriage return somewhere above its paragraph) and then it is fine, the problem is not within Scrivener. (Aside from possibly the font hinting I first mentioned.)

1 Like

Hmm. Full made Segoe UI slightly worse and Candara slightly better.
Segoe UI, Candara
(They look the same to me.)
None (or Vertical) is probably the default because I saw no change from it.

That’s better if using Segoe UI.

So things are working normally for you? I’m back on my old computer (still Windows 10), so I was wondering because there are two things, but I don’t see a reason it would be me. Unless I need to reinstall Scrivener or something

Thanks for your help. I can see the spellcheck warnings if I use Segoe UI and can almost see them using Candara

I just tried Candara. No go. I get what you get.
Use another font. :wink:

P.S. Sorry if I took so long, I did not realize until now that your issue was font-specific.
I thought you had display issues plain and simple and that you were only mentioning these fonts because they’re the ones you use and would have the same issue no matter which. My bad.

Candara doesn’t work for me either. I have no idea why. All I can say is that the fonts that come with Windows are not 100% reliable all the time.

In case you insist on using Candara for whatever reason :

1 Like

But none of them are fully working for me. Arial’s basic, right? :smiley:

Segoe UI, Arial
(dots where it looks thin to me, if it will help the team)


Hmm, strange, with “No Hinting”, I do indeed get a very bad result from Candera (but not Segoe), while everything is very easy to see with “Full Hinting” on both:

No Hinting on left; Full Hinting on right (using wavy lines setting for spell check, which is for me more visible in general than the dots).

The above is with Windows 10 by the way. I don’t see it mentioned, but was this originally noticed in Windows 11? I would imagine that could make a difference, particularly if the fonts were changed. I do overall agree that some fonts just work better or worse than others, in the text engine used by Scrivener. There isn’t a whole lot we can do about that, beyond providing access to the settings we have, as some fonts work better than others with different hinting settings. Other than that, we have to wait for the framework to gradually get better (as it has).

1 Like

I’m running Windows 10

Hmm. Using Full Hinting, I do see same-sized strike marks, though not as thick as yours

Ohhh-kay :smiley: