Speech not working


I installed the new update today. Just tried to toggle settings for Speech so I could proofread by listening, but Speech has stopped working entirely.
Anyone else having this issue?

This is one of my favorite topics, probably because I have been playing with synthesized speech on computers since the TRS-80 Voice Synthesizer in '79.

Go to:
Edit > Speech > Settings

What Engine is Scrivener set to? I’ve been using winrt because the voices sound better than sapi voices.
Windows 10 comes with David and Zira.

If you go into Windows settings and search for speech settings, you can download voices for your computer. I’ve downloaded George and Hazel. They sound more natural, in my opinion.

Make sure you have a language/country selected in Scrivener that has voices installed for it.

My computer isn’t set up to use the mock engine. So those voices have no audio. Mock could just be a mock-up of some kind for testing (on my computer, at least).

1 Like

I’m having the same problem. I was listening with one voice while in Speech settings, and changed the voice, and now nothing plays at all. I’ve tested the voices directly through Windows, and noticed something else - the default US English voice Mark is no longer available in Scrivener as a choice.

I closed and reopened the app several times, and still no speech playback.

We’ve had a few help tickets with this issue.

Please download and unzip the attached qtexttospeech_winrt.zip file:

qtexttospeech_winrt.zip (26.0 KB)

Then, with Scrivener closed on your PC, please move the qtexttospeech_winrt.dll file into the “texttospeech” folder in the Scrivener installation folder.

On most PC’s, the default installation location for Scrivener is at C:\Program Files\Scrivener3\texttospeech\.

You can drop this file into that folder while Scrivener is closed and on relaunch, the voice should be present again in the speech settings. Re-select the desired voice settings, and then speech should work fine.


Thank you, RuthS!

I just followed your instructions and it’s finally working again!

Sorry for the late response. I was using default.
But the instructions that Ruth gave below have fixed the problem.


Hi, I have the same problem and found this thread.

Following these instructions indeed got the winrt engine available and working again. However, the SAPI voices still don’t work. I can select that engine and voices in it via the Scrivener settings, but nothing happens when I read either the demo or try to read any text.

That’s an issue for me because it means I’m currently unable to use the vastly superior CereProc voices for which I have licenses. Is there anything we can do to get SAPI working again the way it was pre-update? I see in that same folder there is a qtexttospeech_sapi.dll so I’m assuming this also requires an update of some kind that perhaps didn’t happen properly with this version?

I have already:
Uninstalled and reinstalled this version of Scrivener3
Verified that the SAPI voices all work normally in other software

1 Like

That one winrt file is the single difference between versions (at least for this aspect), restoring it to the folder should result in an identical configuration as before. Further as I understand it, nothing should have changed about SAPI voices (unless perhaps there were some interdependencies between the two).

I suppose you could try installing from the previous 3.1.5 update, though in theory it should result in the same three files you have in texttospeech right now. By the way you should be able to just run the installer rather than doing a whole reinstall.

This worked for me too. That third winrt file was missing. Thanks!

I now have all three and my speech came back.

1 Like