Spell check entire project?

When I use the spelling / spellcheck feature, it only checks the current file where my cursor is. This happens even when I’m in the Scrivenings mode where all the files are shown, with a horizontal line showing the division between files. There are definitely spelling errors later in my project.

I don’t want to have to go into each individual file to check the spelling. How can I spell check my entire document?

Is there really no way to spellcheck an entire document?
Or how about select all of the project text in the whole document to, say, change the font everywhere?

I’m having the same two problems

How do you spell check the entire document?

How do you change the font, the font size, and the right margin for the entire document?

I’m using Windows 7

I too am having this problem. This question was asked a month ago. Is there no one who can answer it?
Scrivener is spell checking individual words as I go along. But after I correct a word underlined in red I want it to jump to the next misspelling in my ms. and don’t know how to do that. I have a 40,000 word manuscript, all chapters are in the same folder. The search/find function works, but I can’t search for misspellings if I don’t know where they are.

I’m not an expert, but a check of v1.6.1 and beta for Scrivener for Windows appears to show that spell checking across multiple documents within a scrivening (composite) view is not supported. Gwen Hernandez’s ebook Scrivener for Dummies mentions such a capability, presumably in the Mac version, but she doesn’t specify Mac and/or Windows in that mention. You might want to post this as a desired feature in the Wishlist sub-forum.

Workarounds for now…

If viewing/editing a single document at a time, can use the following menu items or keyboard shortcuts to move between documents.
View > Go To >
Previous Document Alt+Shift+Up
Next Document Alt+Shift+Down

If viewing/editing multiple documents in a scrivenings (consolidated) view, can use…
May have to strike the key twice… first time to get to top or bottom of current document, then again to move into the next document.

Hope that helps.

Thanks very much, SpringfieldMH.

Just learned something regarding the keyboard shortcut for Tools > Spelling (i.e. Ctrl+G, Ctrl+Q)…

“you need to use Ctrl+G, Ctrl+Q all together, not one or the other. So, e.g., hold the Ctrl key then press and release G, then press and release Q, and release Ctrl.”

And some useful followup info from MimeticMouton…

“combos like that aren’t as common; it comes from having a lot of menu options that want shortcuts, like in Visual Studio. You may want to go to the Keyboard tab of Tools > Options and change shortcuts for items you use regularly–you can always remove them from items you don’t use to free some of the simpler keystrokes.”

And got an answer… spell checking entire project is currently supported in Mac version, but not Windows version.


thanks for at least confirming I"m not crazy…

Now, another one. I’ve put a compile ebook in .docx on my right monitor.

I am using the spell checker in Word.

When I get to a word that isn’t spelled correctly, it tells me what is wrong

I then move my mouse to the other screen, and using the find, search for that word in Scrivener for Windows Beta on my other monitor. It provides the pages in the table of contents that have that mis-spelled word and when I open those pages, that particular word or phrase is highlighted in yellow, so it’s easy to find and fix.

Now, after an entire day of spell checking, well at least 5 hours, all of a sudden, my cursor doesn’t show as a blinking line anymore. I can’t tell where in the word I am if I space. I can get to the word and the cursor is an arrow. I can highlight the word and change the whole word, but I can’t click through the letters in a word to change one letter.

What happened? I must have selected something that has turned off that particular feature. It was working all day, but now it’s not. I’m sure I am not crazy. I did have that capacity until just the past hour.

Guess what, I tried something. And got it fixed. I clicked on the Outline mode as it wasn’t yellow, and what do you know, I have the cursor blinker back.

Wonders never cease. I must have unclicked it. If I unclick it, the cursor goes off, if I click it, the cursor goes back on.