Spell check not available[ADDITIONAL INFO]

I still cannot find any spellcheck.
I begin feeling like some kind of idiot.
Right clicking a word shows “spelling”, but there’s no dictionary.
Should I download one ?
It seems willing to “learn”. Should I all fill it on my own ?
But why then is there not one single word underlined in red ?

The application is already performing a spellcheck while you are writing using the aspell built in dictionaries. I believe this works based on whatever your system language is set to.

To change how/when it is performing a spellcheck go to:

Edit > Options > Auto-Correction find “check spelling as you type” and “Correct Spelling errors as you type.”

Personally, I usually leave the first option checked and the second option unchecked.

But, if you would like to run a traditional word count on the fly, you can Right Click anywhere in the document then use Spelling -> Show Spelling. This might be more close to what you have in mind for spellcheck.

Did these suggestions solve the problem Lilith?


That is exactly how I use it too. And there is nothing looking like red underlining in any of my texts (in any of the languages I use, even English). (I know for sure, I do NOT type without any mistakes :blush: )

Last night I changed these settings, as suggested to me in another post. (I’ll add a link here as soon as I find it back)

Nothing changed.
Then I turned the options on again, except the one for “capitalizing i”.

Today, when I opened Scrivener, I had the message related to in the present post : “Cannot load dictionary FR_BE”.
As I have never asked for FR_BE (being unable to find what is needed), this sounds even more weird to me : Only my keyboard settings are FR_BE… !
My language settings are FR_FR.

And :

No, not really. Thanks for asking. But there is no change in spell checking.
The only thing that changed, is that now “Si” is spelled right, without two caps.
And this is related to the other post.

Yes, this is a real issue. I had the previously reported failure to load dictionary on install and now I have no spell check.

I can see a lot of problems with the use of the system language. For one my PC was originally destined for the Belgian market and really a Franco Flemish spell check is of no use to me at all. Also I might want to write in a different language - and yes perhaps I might want to write in American English not British English. At the moment the only resolution I see to this is to write in Word so I can use the appropriate spell checks and then copy paste into Scrivener. This is pretty pointless…

Edit: Ah! I finally found the bug list, which isn’t marked as recently updated but it does mention no foreign language dictionaries. I guess this is the root of my problem as the attempt to install a dictionary based on my OS has resulted in there being no spell check. I assume that the final version will have the ability to change dictionary for spell check in the Options?


When I wrote this post, I knew that there is no other dictionary available but English, as I did read the bug list shortly before.
The problem is not that there is no dictionary for French, but that there is no dictionary and no spell checking at all.

Even when I am writing in English, there is not one single word underlined in red.
This makes it difficult to find the words in my files to correct them : printed page does not look the same as my Scrivener screen, of course, and “find” does show me the right file, but does not hightlight the searched item inside the file.

I used to teach MS Word, and I’m still a super user with this program.
This means I know what I’m looking for, and that, especially on this point, you may trust me.
Unless there is one function to turn on (which might not at all look like something I know), there is no spell check at all.

I mean : as I type in French, with only an English dictionary, all my words should be underlined in red, and they aren’t.
I did no change in language settings (did not even see any).
I’m patiently waiting for this, as it is really not urgent to me.
I only want to report this, as I should at least notice something, with “spell check as you type” turned on.

Scrivener Beta 1.3 on Win7 Home Premium (French version), language settings FR_FR, keyboard settings BE_FR (which do not affect each other).

Lilith, it is my recommendation that you uninstall and reinstall from scratch. You can do this now, or wait until the next beta is released. I have seen in recent days someone whose beta 1.3 was having bug characteristics from the previous versions. An uninstall and reinstall fixed this for them, and it might do the same for you.

Project files are not touched by an uninstall and reinstall, but I recommend you back them up in a second location just in case.

Thank you, mithtygitis !

I’ll do that with the new beta 1.4, as we have to uninstall anyway.
And there’s only one more night to sleep before Santa comes…

Hey lilith, did your spell check come on in 1.4?

This is exactly the problem I’ve been having.
I have tried to get it to work by doing a complete uninstall/reinstall without success but perhaps I missed something.
I’ll do some further tests and see if I can get it working.

Nay, still the same.

I will not complain : I read my work on paper too, and I correct. I’m quite a good spell checker myself.

Now, the worst thing is that my cursor does not reappear.
So for doing my own spell ckecker job, it becomes somewhat difficult :laughing: .

If Scrivener were not such a great tool, I think I would now return to Word, but I don’t.

I’ll go and get my broom to see if that cursor has not fallen under my desk…

New installs will not fix this problem until foreign language support is added to Scrivener. This is a listed bug in the 1.4 bug list.

It doesn’t matter what language you are typing in, the problem occurs on install because of the auto language selection in the install program. If you have a non English OS then Scrivener will not install a dictionary and without a dictionary there is no spell checking regardless of what you might type.

As I’ve stated before everything about my laptop is English except the very base levels of the OS. I even have a QWERTY keyboard and everything from a user point of view is in English. A very few programs will detect however that the base OS is Flemish, Scrivener being one of them.

On loading the first project on 1.4 I got the error message again about not loading a dictionary. I don’t know which dictionary it tried to load as the text doesn’t wrap so I can read the end of the error message.

I can confirm that reinstallsing does not fix the problem. Neither does changing system languages or locations. I’ve spent several hours uninstalling and reinstalling the 1.4 Beta without the spell-checking problem being solved.

What follows are my notes made during the testing. As I didn’t manage to correct the problem I am not sure how useful they will be, but I include them for completeness and for the reading pleasure of Lee if he should want to see what measures have been tried and failed.

Anyone not interested can feel free to stop reading here.

All the following test were performed on my Asus Notebook running Windows 7.
When the notes say that there Is no sign of spell-checking working that means that I have typed nonsense words to see if spell-checker reacts and also I have selected a passage of nonsense text and asked Scrivener to recheck the spelling of that selection and neither attempt has worked.

Back-up of current project to external flash drive.

Changed keyboard setting to English

Started Scrivener. Spell-checking not working.

Turned Check spelling as you type off and then on again. No change.

Started new blank project. Spell-Checking not working.

Turned Check spelling as you type off and then on again. No change.

Closed Scrivener.

Used the uninstaller for the 1.4 beta to uninstall scrivener.

Moved all my scrivener projects and backups to external flash drive

Checked the uninstall function on the windows control panel to see if any traces remained. Chose uninstall through this method as well to remove the entry for scrivener in that program list.

Deleted scrivener folder from C:/Program Files

Noticed that the keyboard had reverted to Swedish. Decide to do install with keyboard set to Swedish to investigate if this is a factor.

Started scrivener 1.4 beta install accepting all defaults.

Declined viewing the Readme file.

Started Scrivener creating blank project.

Get Error loading dictionary message for Swedish wordlist

Typing nonsense in the edit window shows no signs of any spell checking.

Turned off and on Check spelling as you type clicking apply in between and after.

Spell checking still not showing any sign of working.

Selected the nonsense I typed earlier and chose Recheck spelling. No evidence of spell- checking.

Uninstalled again using scrivener 1.4 uninstaller.

Deleted scrivener folder from start menu

Checked the control panel uninstall function. No trace of Scrivener there.

Deleted Scrivener folder in C:/Program Files

Changed keyboard setting to US keyboard.

Started installer for the Scrivener 1.4 Beta.

Noticed that keyboard settings reverted to Swedish as I get to the window with the license agreement

Changed keyboard setting to US again.

Started Scrivener and found that the keyboard setting reverted to Swedish as I started it.

I get Error loading dictionary message.

For some reason it remembered the blank project I had started after the last install.

No evidence of spell-checking.

Closed Scrivener and restarted. This time I changed keyboard to US as the beta information window opens.

I get Error loading dictionary message.

No evidence of spell-checking.

Unchecked the Check spelling as you type and clicked apply, then rechecked the option and clicked apply again.

No evidence of spell checking.

Used 1.4 uninstaller.

Checked start menu to see that Scrivener was gone.

Checked uninstall function in control panel to make sure that all traces of Scrivener was gone from there.

Went to the region and language settings of the control panel and changed the default input language to US English.

Started installer for 1.4 Beta again accepting all defaults and declining to view the read me file.

Started Scrivener.

Got Error loading dictionary message.

The test project still appears.

No evidence of spell-checking working.

Turned.off and on check spelling as you type as I did previously.
No evidence of Spell-checking working.

Uninstall using 1.4 uninstaller.

Note: For the first time during these tests the uninstaller tells me it needs to restart the computer. I tell it to go ahead.

Checked start menu and control panel for lingering traces of Scrivener.

Removed Scrivener Folder from C:/Program Files

Install using 1.4 installer accepting all defaults. Declining to view readme file.

Started Scrivener. Received error loading dictionary message.

Same project opens up.

No evidence of spell-checking working.

Turned off and on Check spelling as you type as I did in previous tries.

No evidence of spell-checking working.

Uninstall using 1.4 uninstaller

Checked start menu and control panel for remnants of Scrivener. None found.

Deleted the blank scrivener project that kept appearing.

Went to C:/Program Files to delete Scrivener folder but did not find it. Checked the Recycle Bin to see if I had deleted it and not remembered doing it. It was not there either.

Changed location settings (both current and default location) in the Windows Region and Language settings to United States.

Install using the 1.4 installer accepting all defaults.

Started Scrivener, creating New Blank Scrivener project.

Received Error loading dictionary message.

No evidence of Spell-checking working.

Turned off and on Check spelling as you type.

No evidence of Spell-checking working.

Restarted computer.

Started Scrivener.

Got Error loading dictionary message.

No evidence of Spell-checking functioning.

Turned off then on the Check spelling as you type option as before.

No evidence of Spell-checking working.

Gave up.

If it’s the foreign language factor, then it won’t get fixed until they open up to other dictionaries. But maybe there is a way for the install to install English anyway for those of you in other countries.

Spell check is non-functional for me too. I use only English, there are no other languages used or installed on my system.

With 1.3 and earlier I needed to turn off the spell check functions because they caused too much text lag. I installed 1.4 last night and attempted to turn the spell check functions back on with hopes they would be usable this time around (I am the typo queen). No luck. All the options related to spell check are there in the options check boxes and the right-click menu, but they do nothing.

For me, this is not that big of a deal. I will compile and check it in Word anyway. But I wanted to note this bug appearing on an English-only system where spell-check previously functioned properly except for slowing everything else down.

Separate bug, you can find out how to fix your install of the new beta HERE.

I can confirm that changing keyboard language or region settings in Windows does not reset the OS language which Scrivener is using to install the dictionary.

You are correct, the foreign language issue is one thing and will be addressed in the new year.

The Aspel dictionary requires two dll’s to be registered in the Windows Registry and some paths to be setup:


I believe I messed up with the previous installer and unregistered these dlls in certain cases - my error.

I plan to release beta 1.5 on or before Christmas, so if you can live with this for just a few more days it would be appreciated rather than trying to provide instructions for registering paths and dlls from the DOS command line. My apologies for this inconvenience.


Don’t worry about it (well, do worry about it but in a laid-back kind of non-heart-attack-inducing way). We all know how hard you work and appreciate it a lot.

If I can have english spellcheck by the next version I’ll be happy. And if I can’t I will live with it, until the commercial version is released if I have to. :slight_smile: