Spell Check Not Working - Different from other spell check b

Spell check is not working for me.

I checked my settings, it’s turned on. I don’t get the red line under misspelled words. Also, when I try Tools>Spelling that doesn’t work either…says “Spell Check Complete” but doesn’t pick up on any misspelled words.

Software is up to date (1.9).
Dictionary is set to English (US).
Changing settings then trying again didn’t work.
Just started happening out of nowhere.
Still happens when I exit out of the project and open it again.
Happens in other projects, not just one of them.

I’ve been having the same issue with mine and it seemed to have started around the last update earlier this month. I’ve noticed that the English dictionary isn’t listed in the drop down menu with all the other languages, but is shown to be selected. Then when I tried to download another language dictionary it didn’t pop into the available menu and there is nothing in there to choose from.

This is how I fixed it.

I went into my Scrivener folder and found the backup it created after the last update. Mine is located at C:\Program Files (x86)\Scrivener\backups

I copied the Aspell folder and pasted it over the one in the main folder. Now it’s showing me all of my dictionary options and I have the red line again.

Hope that helps.

That worked! Thank you so much, I really appreciate it!