Spell check not working

Hello! Forgive me if I’m in the wrong section, but it seems that when ‘check spelling while typing’ and ‘check grammar with spelling’ are on, spell check doesn’t work. I’m using Mac High Sierra 10.13.5 and Scrivener 3.0.2 is up-to-date. (My preferences also have spell check on too) so I thought I’d report this as a bug. If there’s a fix for it please let me know. Thank you!

I don’t have a solution, but also have the same problem.

You’re lucky. I can’t even get auto-complete to work on Scrivener 3.0. Or even find Options…

Items to check for Scrivener 3.0.3:

System Preferences > Keyboard > Text > Correct spelling automatically (and Capitalise words automatically, if needed)

And Scrivener > Preferences > Corrections > Correct spelling errors as you type

And, for each project, Edit > Spelling and Grammar > Check Spelling While Typing

And, optionally, Scrivener > Preferences > Corrections > Fix capitalisation of sentences

Slàinte mhòr.

Thank you, this worked for me. For some reason, it was the System Preferences (of my MacBook) that was the issue.

I did everything you suggested, but Scrivener 3 doesn’t recognize words that should be in the dictionary or offer suggestions. And when I ask it to look up a word that I know should be there, it doesn’t connect to the dictionary. Any other suggestions?

Brilliant --this checklist helped me get to the bottom of things.

Glad it helped.

Slàinte mhòr.

After doing this, close the file and quit the application. Then reopen.
The suggestions below had no effect for me until I quit and reopened. Just updated to S3.1.3.

I’m having the same issue with 3.0.4 and mojave 10.14.6 - restarting Scrivener fixes it, but only temporarily.