Spell Check refuses one file, works on another.

Has anybody encountered this?

I have a simple project: two text files, one above the other in the binder. When I click in the first file, then open the Spelling dialog and click Find Next, Scrivener gives the error sound. When I try the same procedure in the second text file, the spell check runs normally.

As an experiment, I did a Select All for the first file, created a brand new text file, and pasted into it. Again, spell check gave the error sound and would not run against this file.

Then I created another new file and placed it, in the binder, above the first, and pasted the text of the second file into this new one. (The idea being that maybe binder location could be a factor–this is desperation.) Again, the spell check worked normally.

My conclusion is that there is something in the body of the first file that is stopping spell check. Is this possible? Are there hidden codes or symbols that can do this? Is there some other factor?


My apologies for posting this to the Bug forum.

I just tried pasting the text from file one into a new file in Pages. The Pages spell checker would not run against the file. When I tried with the second file, Pages was able to spell check it.

This only figures–I see from other postings here that Scrivener uses the system spell check feature. So if there is a bug, I guess it is Apple’s.

But why is this happening?

Are there any foreign words in the document that isn’t working? (By “foreign”, I mean words in a different language to the rest of the text.) If so, check what language is set in the spell checker. Snow Leopard introduced an “Automatic by Language” setting, and it seems a bit flaky. It tries to detect the language you are typing, but when more than one language is used, although it is supposed to detect this and then spell-check both languages, it often seems to get confused and stop checking anything. If this is the case, try setting the language specifically rather than using “Automatic by Language” and see if that helps.

All the best,

All right. Never mind. I’m a complete idiot.

There are no foreign words. But it turns out there is a foreign spelling.

Yes, last night I did notice the Automatic by Language setting, and so reset it to US English, but it had no effect.

Now I tried other settings: Canadian English seemed to fail; British English and Australian English both succeeded, highlighting the horror of “realized” and suggesting the wretched “realised” instead.

The point is, the spell check is not broken and there is no bug. The “error” sound the system was making was simply spell check notifying that the check was complete and that there were no errors. I assumed that out of 1,205 words and a bunch of hasty edits there had to be typos.

Sorry about that

On what possible grounds can “realised” be considered wretched?

It doesn’t have enough l’s to be British.


Ha! In the case of checking more than 100 words, I think the system’s “no spelling errors found” sound should be a freaking chorus of Halleluiahs. Ever since the typewriter became obsolete, the incentive to learn to type and spell perfectly from the get-go has evaporated. Since I was on the cusp of that change when I learned to type, the event of an error-free 1,200 word document would be cause to buy a round of drinks in celebration.