Spell Check

Spell check isn’t working despite suggestions I’ve seen here. I have an old ipad (version 9.3.5) and General Settings>Keyboards doesn’t even give a spell check option. I have spell check on in the main Scrivener app settings. Someone said that spell check also needs to be chosen per project. So I followed those instructions but when I click on a project and then click Edit, it only gives me the option to reorder the folders/files. I’m not seeing a way to turn on spell check per project. I’ll include screenshots of the menus I’m referring to. Thanks!!

It’s auto- correction.

Hope this helps!

I don’t want it to auto correct. I just want it to underline misspelled words.

iOS does not have the underline-style spell check. Only auto-correct is available.

Thanks. I saw a post by Repelstale on here regarding spell check. Their issue was different than mine but they said newly typed misspelled words were underlined in red in the Scrivener app. So I’m confused… :confused:


If you go to the Settings App, scroll all the way down until you get to Scrivener (NOT in Scrivener itself, but in the Settings App), tap on Scrivener, and then tap on Spelling and Substitutions, you can turn auto-correction off and check spelling on for within Scrivener only. That will get the underline effect that you want. BUT—

It will NOT stay underlined once you leave the document. Not even within the same project inside Scrivener. Go work on another document in your project, come back, and the “misspelled” underline will be gone. There’s no way to “scan” a document for misspellings under iOS. It’s strictly as-you-type, forgotten as soon as you go on to something else. If that works for you, there you are.

Hope this helps.

Thanks. My issue is that I actually do have that setting turned on but it’s not doing anything. That’s the 2nd pic I included that shows I have spell check on in Scrivener app settings. It’s just not doing anything. So odd.

I have no further suggestions to offer. Unless someone has your specific iOS version, I have no idea how to proceed. :frowning: Sorry I couldn’t be of more help.

Thanks so much. Maybe I need to reinstall or something. :neutral_face:

It’s working in 9.3.5 for me. Enable the setting for Auto-Correction at Settings app > General > Keyboard; Check Spelling should appear. Enable it, then if desired, disable Auto-Correction. Strange procedure, but possibly “it’ll just work”.

I was just about to post because I just stumbled on that!! Turning on auto-correction makes spell check appear. :slight_smile: If you turn off auto-correction, “spell check” disappears. Got it working! Thanks!