Spell checker - Can't correct a word...

Within Scrivener the word Artifacts is correctly identified as being incorrect, but the first replacement is “Artifacts”… the same word.

Within anything else on my system the correction is made correctly. In fact in Textedit the auto correction is automatic.

Is this normal?

Check your spelling settings to ensure it’s using the correct dictionary - it’s spelled “artefact” in British English, for instance, so maybe your dictionary isn’t set to US English in Scrivener?
All the best,

No, it’s definitely set to British English. And as you’ll see in the screen grab it correctly identifies artifacts as being incorrect it just can’t correct it.

Is it possible the “This word is incorrect” and “Here are some suggestions” logic is being handled by different dictionaries?

Oops, sorry, that’ll serve me right for replying halfway gone on a Friday night - I completely missed the point.

Where did you check the language? Have you checked the spelling panel in Edit > Spelling and Grammar > Show Spelling and Grammar? Remember that applications can have their spelling language set separately. This is working fine on my system - “artefact” comes up in the list of suggested spellings in Scrivener for “artifact” - and as the list of suggestions is returned by OS X’s spelling services and not determined by Scrivener, it must be a spelling setting somewhere.

All the best,

I saw it again with another word (I’m a terrible speller when I’m tired), but cured it by restarting Scrivener.

How are you accessing the list of suggested replacements, by the way? You seem to have many more options than I get, and I’m wondering if you might have additional dictionaries installed on your system that Apple’s using and that one of these is offering the American spelling even though it shouldn’t be.

Excuse my stupidity - I can’t find the manual either on my own system or on this site (I can find the short manual within Scrivener, but not the longer one). How do you change the language setting? Scrivener has decided to use American spellings for some reason, and I can’t see where to change it.

I’ve searched for “change dictionary” “UK English” etc, both here and in the app, but with no luck so far.

In one reply to the same question I found in an Apple forum from long ago, it said there should be something called ‘More’ under the Inspector; can’t see it now, though.

I’ve searched “Take Control of Scrivener” for “UK” “language” and “dictionary” without finding a solution.

ps - “Excuse my stupidity” isn’t sarcasm, by the way, I do feel a bit dimwitted not to be able to find the manual when it’s obviously staring me right in the face. If someone could post a download link I’d be very gratetul; and maybe just tell me how to change the dictionary too, if anyone has the time to steal from proper writing.

In the Scrivener Help menu, the top item. (Not sure what you mean by the “short manual” , but that’s certainly a long one!)

Edit > Spelling and Grammar > Show Spelling and Grammar: at the bottom of this pane there’s a drop-down menu which, if you click the small black arrows alongside, you will see lists the languages available, including British English. Click on this.

Edit: this all assumes you’re using version 2. I no longer have version 1.5 to check.

Yes, v2, Hugh, but that’s not what’s appearing on my Edit/Spelling and Grammar menu (which was, of course, the first place I tried, long tearful hours before coming here to ask for help). It just shows:

Show spelling and grammar
Check document now
Check spelling while typing
Check grammar with spelling

Oh, wait, I see that under “show spelling and grammar” there is a menu. Thanks, that’s fantastic. (On the new computer it had set itself to “automatically by language”, which queried some UK English spellings.)

By the way, the reason I think there’s two manuals is that people here sent me to a longer one before. But maybe it wasn’t called a manual but a tutorial, or something.