Spellcheck Language Keeps Reverting to System Default

I would like to use the Scrivener spellchecker using American English, but keep my computer default as Canadian English. I can change the language to American English from the spellcheck dialogue, which works temporarily, but whenever I close and reopen Scrivener it reverts to System Default. Is there a way to change this permanently, or do I have to change it every time I open the application?

I’m using Scrivener 3.3.6 on MacOS.

Hi Prunesquallor, and welcome to the forum.

In your Mac’s System Settings, do you have American English added as a secondary language to Canadian English?

If not, you might add it and see if that improves Scrivener’s behavior. It might not, but I’ve seen it help on my system for with Spanish.

Thanks for the suggestion. Unfortunately it didn’t work. It still switches from US English back to “Automatic by Language” whenever I restart Scrivener.