Spellchecker not Checking

Hello!

Scrivener is up to date (1.9.16.0), but I’m having issues with the spellchecker. And that would be that it’s not doing anything. :unamused: I quadruple checked that I have Tools>Options>Corrections>“Check Spelling as you Type” and “Correct Spelling Errors as you Type” and it still isn’t working.

I’m working on several projects and it’s consistent across all of them. it’s driving me nuts to have to paste into Word to spell check, then paste the spellchecked version back into Scrivener (and then reformat it, ugh).

It seems like there’s a second way to activate spell checking for Mac OS, but the manual isn’t providing any answers about alternative routes for Windows.

I never thought I’d say I miss the spellchecker squiggles, lol.

Update: It also doesn’t work to manually check the spelling either (I get the pop-up that it completed successfully, but nothing is flagged, even words I know as misspelled (because they’re made up words).

Thought I’d update this post in case someone else runs into a similar issue in the future and goes searching for solutions like I did.

Ultimately, I gave up and just uninstalled and reinstalling the program and it seems to have fixed the issue. My Scrivener files are all intact, and there seem to have been no negative effects. I am please to report the squiggles are back! :laughing:

I am having the EXACT same problem, using Scrivener for Windows 3.1.1.

When opening the Spelling tab for a document, I get the Spellcheck window. But there’s nothing in it.
It’s got nothing but blank fields, even though there are misspelled words in the text.

How did that happen? It wasn’t doing that before moving to version 3.

I have the full document viewed as Scrivenings. In the Spelling tab under Options, I have tried both enabling and disabling Correct while typing. That doesn’t make any difference.

I’ve seen other users with similar complaints for the MacOS and the Linux versions.

What’s the fix??

HELP

This is what I have:

This makes no difference in my case. I’ve used the default settings, and I’ve tried to modify them to test the options.

BUT NOTHING CHANGES. Spell check doesn’t work. What gives?

Try rebooting Scrivener if you haven’t already, and if that doesn’t help, reboot your computer. After that, your best bet is to uninstall and reinstall Scrivener.

1 Like

Don’t forget to check for updates in Windows.

2 Likes

Boy, the general advice here hasn’t been effective. I can update Windows. I can reboot Windows.

Really? Come on, people. It’s not that basic.

So I’m still faced with no solution. Am I the only person (with version 3.1.1.0 for Windows) that can’t use spell checker? There’s got to be a developer from L&L somewhere who’s got a clue on why this is happening.

Actually it is. There are three basic ways to have spell check work. One is to not run any spell check at all. which is what you are saying is happening to you now. Two is to show you what the spelling errors are by using a series of red dots which may be hard to see - I changed mine to red waves. It does not automatically correct the error. Three is to have spell check going and do auto correction as you type. You have those choices.

What exactly are you seeing? What are you expecting?

Here are some screenshots of what I have setup in my Options:


Some text in Scrivener to show what I see when I type:

Using the Scrivener Spell Check option in the Edit menu:

Which opens this dialog:
Screenshot 2022-03-23 133224

1 Like

What are we missing? This looks like it’s working exactly as intended.

Yes, it is (for the OP to check their options I posted mine). Still waiting for the OP to post.

1 Like