Spelling & Special Characters


I have two questions regarding spelling and special characters:

I write in Spanish and I would like to know if I can turn it on in this language so I have the squiggly lines when I misspell something, instead of having to open the Spellcheck.

On the other hand, I want to know if there is a feature like the AutoCorrect in Microsoft Word, i.e. when I write a set of characters, they automatically get replaced by an special character. In Spanish the quotation marks are not “” but «». When I use Word I have set it that when I write << or >> they get replaced. Is there a way to do this in Scrivener?

Thanks a lot

Dictionary languages are controlled by maOS in Preferences/Keyboard/Text/Spelling

Set this to Automatic by Language, then select the languages you use. I use British English, Spanish, and French, and it works fine in Scrivener.

Similarly, autocorrect-type functionality can be set via Preferences/Keyboard/Text in the Replace/With panel.

Is there a way to switch it off only for Scrivener and not for all applications (i.e., through general preferences)? Ticking the box off in Scrivener preferences doesn’t work for me. I still get the squiggly line.

Any suggestions?

Thank you,

Best regards,

Hi !
I have the same question but on Windows : Where can I find the “preferences” menu ?
Thnaks in advance :slight_smile:

On Windows, it’s “Options”, not “Preferences”, but if you need help, you’d be far better off posting in the Windows forums.



Hi Auxbuss
Thanks a lot for your answer and sorry for the delay in thanking you :wink:

Where do I set up the languages in Scrivener? I don’t seem to find it.


Apple > System Preferences > Language and Region
Apple > System Preferences > Keyboard > Text
Scrivener > Preferences > General > Language

Hope that helps

Mark (@auxbuss must be asleep at the moment, I think :smiley:)