Split screen options

Is there a way to control how split screen chooses to appear?

I often use horizontal split screen. The current behavior is that when I split the screen the bottom editor displays the section I am working on, while the top screen goes to the beginning of the document.

I would prefer that the top screen shows the section I am working on. Is there a way to make it happen?

Better yet would be if split screen worked the way it does in MS Word wherein the screen splits in the middle and the document on both sides doesn’t move.

When you split, the top editor has focus.
Perhaps you could set a macro that would include the shortcut to scroll to cursor position ?
Macro → Split, then scroll to cursor position.

I wish that was the case. With me it is the bottom that has the focus.

I want to use the top editor for writing and the bottom for accessing my research. Now I have to do it manually.

Is there a way to make the top editor the focus?

With a macro, yes.
Macro: Split - Move focus to top editor - Scroll to cursor position.

If it is systematically the same editor that has focus after splitting, that should work.

P.S. Not at my computer, these may well not be the exact menu functions’ names.

View > Editor Layout > Split Horizontally
Navigate > Move focus to > Top editor
Edit > Find > Jump to selection

Use the Mac equivalent of Auto Hot Key ?

And for after the split:
If you set the options so that a binder selection always loads in the top editor, then there is a key modifier to rather load in the bottom one.
Under windows it is Alt+click.


So Alt+click opens the document in the bottom editor.

Or set it the other way around. Your preference.

It seems I used the wrong terminology I used “focus” rather than “editor.” I want to swap the editor.

Currently when a document is split the editor that originally was dealing with the text in question is the bottom editor. I prefer it to be the top editor.

The command for that is View>Editor Layout>Swap Editors. That does the job.

But if I close the split and open the split again I again have to re-apply the command. It seems that keeping the editor in the bottom screen the default and can’t be permanently changed.

I created a hotkey “cmd+E” that makes it easy to do every time.

Perhaps then use a copyholder instead.
Set the copyholder to be at the bottom of the editor, set a shortcut for

Of course, what helps is to scroll the cursor in the top half before you split the editor. No matter by which means you split it.
A little nudge of the mouse wheel prior, is all it takes.

I don’t understand though how jump to selection can not be your solution.
If the top editor has focus, that should be the only command you need.

(Assuming I got the big picture right, that is.)

→ Under Windows, the split is actually a real split. Part of the text hidden behind the header of the second (bottom) editor.
None of the two editors actually scrolling to anywhere. [EDIT] After a couple of times trying it out, the bottom editor started losing its position. I don’t know what’s up with that. (But it doesn’t really make any difference here anyways…)

From that I can take a guess and say perhaps you have typewriter scrolling on, and that makes your active editing line end up hidden by the second editor’s header ?
→ Mouse-wheel nudge prior. Or jump to selection as a shortcut.

When I got a single editor and use the menu item (or its keyboard shortcut) View/Editor Layout/Split Horizontally then the focus is on the bottom editor (indicated by a thicker line beneath the title bar).

When I got a single editor and click on its split icon rightmost of its header bar then the focus is on the top editor.

In the latter case the cursor might not be visible after having written in the bottom part of the visible content of the single editor before the split. Because now the upper editor only shows the upper half of the the content that had been visible in the single editor. This can be prevented by active Typewriter Scrolling (View/Text Editing&Typewriter Scrolling).

Please note that the top and the bottom editor (same with right and left) have their own settings for Typewriter Scrolling. I might be helpful to drag the Typewriter Scrolling into the menu bar as it is not just a button to toggle Typewriter Scrolling but also an indicator of its state (blue = active).

If I got you right, @Orpheus, using the split icon instead of the split menu item/keyboard shortcut is the solution to get the focus on the top editor. (Please note that you will have to close the split editor with the split icon of the top editor to give the top editor focus once you split again.)

In addition to that you might activate Navigate/Binder Selection Affects/Other Editor or even Navigate/Binder Selection Affects/Bottom Editor. So when you click on an item in the Binder while your main text is in the top editor you get your references always in the bottom editor. Play around with the settings a bit to find the solution that suits your workflow most. You can toggle the editor an items gets opened in by option-clicking.

I hope I could help.

It is not focus, it is about the editor. I used the wrong word before.

Suppose I am working on a document and I want to look at some research files to get info to put into my non-fiction work.

So I split the screen. What happens in my case is that the part of the document where I am working is now in the bottom editor, and the top editor is now showing the beginning of the document.

To me this is counter intuitive and I want the part of the document where I was originally working on to stay at the top, and the bottom editor will be used for digging around in my research folder which is at the bottom of the binder.

I hope that is clear.

In any case I found a solution.

When you split the screen, you have two Editors. Your issue is which one gets focus when you click on a Binder document.

Absolutely, and it was before to me. But I on the other hand wasn’t clear it seems so I try again. (By the way: The use of split screens you are describing is the same I handle them.)

How? Like I said, there is a difference between what the menu item (wether by clicking or by keyboard shortcut) does and what the split icon on the right of the editor’s header bar, right beside the Go to previous/next document arrows, does.

With a single editor open click on its split icon. The upper editor’s text should not move, the text in the bottom editor will jump to the top of the document. The top editor will have focus which means it shows the cursor.

If it is the other way round, close the split editor by using the split icon on the header bar of the upper editor. Then click on it again to get a split editor. Now the top editor should be in place.

It is important to know when using the split icon Scrivener remembers which editor was kept when “un-splitting” and gives it focus (and text unmoved) when splitting again. So in your case: Always use the split icon of the top editor. Since it is exactly in the same place as the single editor’s split icon it is easy to remember for the muscle memory.

So this should give you the editor behaviour you want.

But what might be confusing is when you had been writing in the lower half of the text visible in the single editor. After splitting you will not be able to see the cursor in the top editor—but it’s there!—as that part is not visible anymore because the bottom editor now occupies that space. When you use Typwriter Mode you won’t be writing at the bottom of any editor and therefore the cursor will stay in the visible area.

And if it is working so far you should definitely play around a bit with Navigate/Binder Selection Affects/… to get exactly the behaviour that fits your needs. When you often hop betweens different reference documents for one piece of your draft you might go for …Bottom Editor. But maybe …Other Editor will do. “Other” refers to the editor that does not have focus (and the cursor).

You also might want to give Navigate/Editor/Lock… a closer look.

EDIT: What might be confusing too is that the term focus is also used for something totally different in Scrivener: View/Text Editing/Focus allows to grey out the whole document except for the active line, sentence, or paragraph. This has nothing to do with what we are discussing here.

1 Like

My setup is that binder selection is opened in the top editor.
Whenever I want a file to load in the bottom editor, I Alt-click it, instead of just clicking it.

Thank you for that explanation. It makes sense. I usually split the screen using “command+'” which gives a different behavior.

I will play around with those other settings that you mention.