Splitting documents problems

I encountered 2 problems when splitting documents:

  1. The note of the original document appeared also in the second document.
  2. Selecting text and choosing ‘split with selection as title’ from the context menu did not do anything (did not split)

Version: Beta (1078454) 64-bit

  1. What do you mean by “the note”? What are you referring to?
  2. Did you actually select some text before trying to split?



Yes, I selected text.
I added a note to a document, then I split it in two and the note is visible in both documents. See picture.

On the first matter, splitting is a bit like duplication, you should expect to see most inspector attributes carried over into the new section (Snapshots are the main exception).

On the second, I can’t reproduce that myself. The command should disable itself if the conditions you’ve provided are impossible, so if it is lit up, it should work. I’ll need a more detailed checklist to understand where the problem is. To provide an example of that detail, here is what I tried:

  1. Pressed Ctrl+N to create a new document in the binder.
  2. In the editor, typed in the following text:

Line one Line two Line three

  1. Placed the cusor at the end of “Line two”, and pressed Shift+Home to select it entirely.
  2. Used the Alt+Shift+K shortcut to invoke the Documents ▸ Split ▸ with Selection as Title menu command. (In a second test, I also tried the contextual menu, as it seems that is what you are using.)

I should mention I’m on a slightly newer build than what you will have, so maybe if you follow that checklist and it doesn’t work, it was something that has already been fixed.

Following along with this, it seems that you need to “Save” the document/project before you do the split. Until that is done, nothing happens when you try to do the split.

Hmm, still no luck. I set the auto-save idle timer up to 15 seconds to make it more difficult for save to trigger, but I was still able to get through this checklist. This is on a pretty vanilla setup, if you factory reset your settings does it make a difference?

Switched to defaults (and restarted Scrivener as requested) and that worked without the save first. Switched back to my settings (restarted Scrivener as requested) and it worked without the save first as well. Don’t know what happened with that first test that required a save.
FWIW, my auto-save idle timer time is 10 seconds.

Strange! Well, it’s worth trying that, mihai. You can save your settings via the “Manage” button in the settings window, before using the “Defaults” button to the right.

Hopefully it’s just a beta gremlin that won’t impact any fresh installs.