Square brackets in Compile


Whenever I compile to docx, or rtf and open in Word 2008, the title has square brackets which I am not able to remove. I’ve searched for this on the boards, but I couldn’t find an answer.
I used Scrivener when it was in version 1. But after some problems with Bookends, I switched to Mellel. I’m now wanting to use Scrivener 2, and have run into this very irritating problem. I am a graduate student, and do a lot of writing, so I hope there is a simple solution.
Thank you,
Gil Tutone


I’m not quite sure what you mean about square brackets - the title where has these? A title inside the Word document, the title of the Word document? Could you please post a screenshot?

All the best,

It happens to me when the very last character of a document has a comment. As it’s not a big problem (no comments on the last character), I haven’t tried to solve it at the “core”.

I’m at work, so I can’t do a screenshot as it is on my Macbook Pro, at home.

The heading (not the header) of the document.

It looks like this:

                                 [This Document]

Then, the rest of the paper…blah blah blah…

I’ve tried rtf, doc, and docx…they all end up with brackets.
If I open it up in Mellel, then export it in doc format, all is well. But this creates too many steps just to be able to open it in Word 2008.
Thank you,
Gil Tutone

Are you using the “Proof Copy” compile format? I believe that one adds square brackets, come to thing if it. Check the title prefix and suffix in the Section Layout panel in the “Formatting” pane of Compile.

I’ve included a screen shot of the a document (as an attachment). I also checked the prefixes and suffixes, and the boxes are blank.
Thank you for your help.
Gil Tutone
Brackets in Word.pdf (192 KB)

Looks like a bug.
To fix it just do this:
‘Compile’ - ‘Formatting’ pane - middle of the pane next to ‘section layout’ button, there should be a tick box for ‘Include in RTF bookmarks’. Make sure it is unclicked for all the levels in the document.
That should let you compile without funny brackets.
The function seems to be recommended and required for table of contents, etc. so I assume its a bug if its behaving this way. Either that or I don’t understand Word.


Hi Joao,

Thank you very much. I appreciate the fast reply.
It did the trick. Everything compiles correctly now.


Joao - thanks for the clue! It’s not a bug, but a setting Gil must have turned on in Word at some point. With your pointer to the bookmarks, I looked it up and found this:

mgxp.blogspot.co.uk/2012/11/word … quare.html

It turns out that if you have “Show bookmarks” ticked in Word, it will place square brackets around bookmarks. This won’t affect the document or cause them to be printed.

To turn them off, simply un-tick “Bookmarks” in the “View” pane of Microsoft Word’s preferences.

Glad to have helped.
It didn’t look like a bug, but I just couldn’t find the setting in Word to hide the brackets (figured it would be in the View menu…).
I had that setting in Word turned on too, so it may be the default setting - might be a good idea to start a knowledge-base for Scrivener-Word integration - it seems nearly everyone expects the final format to be in Word these days. Gill might like to take a look at this post for example, michealaxelsen.com/blog/?p=2989