Stop printing comments inline in 3.0

Hello all,

I recently upgraded to version 3.0, and I Iove it (almost). I included comments in my manuscript in the prior version. They showed up only on the right side of the screen (not in the document) and they did not show up when I printed the document, which is just what I wanted. When the manuscript was converted to version 3.0, the comments still show up on the right side of the screen, and each comment is titled “comment,” but they print inline (in the text) whenever I print the document.

I unchecked the Inset Linked Comments box in the Print Settings dialog box, but nothing changed. As an experiment, I also checked the Remove Annotations box, and nothing changed. Strangely, when I called up the Print Settings dialogue again, the Remove Annotations box was unchecked. I checked it again, clicked OK, called it up again, and the box was unchecked again. I never used inline annotations, so that does not seem to be relevant anyway.

I looked at all the menu times across the screen, and nothing else seems to be relevant. All the Google search result are very old and do not appear to be applicable . Section 26.1 in the user manual seems to be the only relevant section, and it tells me to do what I already did, so I am now lost. Help!

Finally, is there a way to suppress the file name and date when printing? There is no option to do so in Print Settings, nor does the manual give the option in Section 26.1. From the manual, it seems like you get it whether you like it or not.

Thanks,
Jim

Thanks for the report, there does appear to be a problem with those two settings having any effect on the output.

For the moment you could achieve a very similar effect with the following settings:

  1. Select the item you wish to print (as normal).
  2. Call up File/Compile... and set the Format in the left sidebar to “Default”.
  3. You can leave the settings in the preview column alone, or set everything to “As-Is” with the Assign Section Layouts... button.
  4. In the right column, in the Contents tab, set the Compile dropdown at the top to “Current Selection”.
  5. You may need to tick the Remove comments and Remove annotations checkboxes in the General Options tab.

Now with the very top option set to “Print”, you should be able to print individual sections easily. You can get back to your normal settings by selecting your usual Format and setting the contents tab back to “Draft” (or whatever you normally use).

Finally, is there a way to suppress the file name and date when printing? There is no option to do so in Print Settings, nor does the manual give the option in Section 26.1. From the manual, it seems like you get it whether you like it or not.

Now as to that one, the File name and date option in Print Settings, at the very top, works fine for me. I did only check with print preview though. (The page number option not doing anything is a known issue.)

Thank you so much for your advice, Amber. Unfortunately, it didn’t work. Just to be sure I did everything right, Formats was set to Default. I made sure the Insert Linked Comments box was unchecked in Print Settings, and the Remove Comments and Remove Annotations boxes were unchecked in the Options “gear” included with the Replace Text, Set Metadata, and Choose Which Documents Should be Compiled “tab” (I don’t have a separate General Options tab). Compile was set to Current Selection (I also tried it by checking the box for the section in the other view). Comments still print inline with the text.

As an experiment, I tried all of the options in the Assign Section Layouts button, from Part Number to As-Is. Every time the text printed, it did so with the comments inline. And yes, the comments are linked comments, not inline comments.

To add to the frustration, I use Times New Roman in the editor. Every time the document printed, the letters were bunched together. For example, in “loved,” the “o” touches the “l.” In “had,” the “a” touches the “h.” Proportional fonts run amok. The document looks terrible.

I probably spent about six hours messing with it, trying everything I could think of. I found a very simple work-around: Select all the text, copy and insert it into a new Word document, select Delete All the Comments in Document, and print.

Don’t get me wrong–I love many things in version 3. Finally, Project Search works, in the same manner as it does in the current version of Word (it never worked in my prior version of Scrivener). Many other goodies, too!

Unless anyone has other ideas, I guess I’ll just wait for tech support to tackle the issue. I gotta get back to writing! :slight_smile:

Just to make sure we are on the same page here: you are setting the compile dialogue at the top to “Print”, and clicking the “Compile” button, and the output has comments and annotations in it? I just want to make sure you aren’t saving your compile settings and then Ctrl+P printing normally from the editor, because the two have little to do with one another.

If you are compiling to print, could you try PDF instead? I don’t myself see the result you are describing.

As an experiment, I tried all of the options in the Assign Section Layouts button, from Part Number to As-Is. Every time the text printed, it did so with the comments inline. And yes, the comments are linked comments, not inline comments.

Yeah that shouldn’t make any difference. The compile settings you ticked are what determine whether comments and annotations are printed. The Format may change how they look or function, but only if you choose to export them. Layouts are even a step removed from that. If you double-click on the Format to edit it you’ll see what I mean. There is a dedicated pane for setting up how comments and footnotes work. Layouts only change how each individual binder item would look—adding headers, changing the font, that sort of thing.

To add to the frustration, I use Times New Roman in the editor. Every time the document printed, the letters were bunched together. For example, in “loved,” the “o” touches the “l.” In “had,” the “a” touches the “h.” Proportional fonts run amok. The document looks terrible.

With regards to that, this discussion should help. The question there is based on export, but there is also a setting for editor hinting.

Alternatively, and for export only, if you have a copy of Office fully installed, you may also switch to using its libraries for PDF output (which may impact print, I’m not positive).

  1. In the Sharing: Conversion tab, click “Export Converters”.
  2. From there you can change the file format to “PDF” and select the export engine to the right of that.

Correct.

Correct - no Ctrl+P printing.

I forgot to mention in my post – I tried that, and the same thing happens. And the relevant boxes were unchecked there as well.

Thank you so much for the additional link. I will review the posts and try the suggestions at a later time.

This may have been a typo, but the options are Remove comments and Remove annotations, and thus should be checked, not unchecked as declared.

Ah, I misunderstood what you meant by “may need to tick.” I read it as “click on it to change whatever is there.” I thought it was strange to uncheck a box that did what I wanted it to do, but as a former computer programmer I know that things are sometimes inadvertently negated because of sloppy programming or failure to count the number of “nots” building up in the algorithm. That is correct–the boxes should be checked, and the problem is solved. I definitely fault myself for not trying that ridiculously obvious combination in the first place. Silly me … .

Many thanks!
Jim

No worries, glad to hear it is working as expected now.