Straight quotes showing up as smart

Despite putting the straight quotes on the keyboard of my iPad, when I click on them, they show up as smart quotes, and I can’t figure out how to make them straight except go back to my Mac and straighten them. Straight quotes that are typed from my Mac version show up fine. Screenshot

Thanks for this amazing app! :slight_smile: I am in awe of the massive amounts of effort that went into it.

Under the binder for a project–any project–tap the gear icon, then tap “Show app settings”. Tap “Smart punctuation”. Set up quotes to your liking. Tap the “Back to Scrivener” link at the top of the screen to finish.

Huzzah! Thank you so much. :slight_smile:

As a slight variation on this theme, one ‘quirk’ (I don’t think it technically qualifies as a bug) in the iOS app is that auto-correct quotes inserted whilst editing in the app (e.g. if you type [hasnt] and iOS auto-corrects it to [hasn’t]) are ALWAYS straight quotes, even if the quotes inserted into the doc through the Scrivener-iOS punctuation toolbar (which is wonderful) are ‘smart’ / slanted quotes. This means that if you are using the toolbar for manually-inserted punctuation — e.g. quotation marks at the beginning / end of dialogue — but relying, as many of us have come to do, on iOS’s native autocorrect to insert punctuation into oft-repeated contractions and so on, you end up with a document that is riddled with inconsistent quotation styles: a hodgepodge mixture of smart and straight quotes.

(This issue doesn’t occur on the Mac version, where in Scrivener settings the option to use ‘smart’ quotes becomes universal whilst editing, including affecting autocorrect-inserted marks — though obviously these are less frequently employed when typing on a full sized keyboard.)

A workaround for the issue is, of course, to open all documents edited in the Scrivener iOS app on the Mac version, select all text within them, and use Format > Convert > Convert Straight to Smart Quotes (or the other way around), which regularises the styling — though this is an annoyance if one is spot-editing various documents across a large project (of course, one can aways open the whole project’s Drafts contents as a single Scrivening view in the Mac version and convert for everything… but this is memory intensive.)

I don’t know if there is, technically, a way to address this in the iOS app?


Thank you ever so much Silverdragon. This has been bugging me for days and I just couldn’t find a solution.