Struggling with Styles Import and Shortcuts

I just upgraded to Version 3. I’ve been using Scrivener for four or five years for all my writing. I use styles extensively while writing–it’s how I keep track of all the bits and pieces, and how I see my hierarchy. And I have a shortcut for every style, which I assign using the OS system preferences.

Two questions. First, I can’t get Styles > Import to work. It either shows me the pre-loaded V3 styles (for projects already converted in V3, or "Nothing to Convert " for projects not yet converted. I know my custom “formatting” is still in those projects.

So how do get my old formatting styles into V3. I read the relevant parts of the manual and I see the new rules (project based styles), which is great. Seems like once I get my formatting imported to one V3 project, I can move them around at will. But I have a lot of old styles and I don’t want to have to rewrite all of them. I want to import.

(I still have V2 on my laptop, everything synced through Dropbox. So I can still go in there and do things, if that helps.)

Second question: what is that short list of Shortcuts available for new styles? They are not the shortcuts I want. Can I get rid of them? And, I just tried adding a shortcut to new style H3 through the OS Preferences, as I always do, but it’s not working. I did get one to work for Centered Line (a menu item), so it’s just not working for styles (Maybe I should start a new thread about shortcuts?)



Version 3 styles are different from the old V2 formatting presets in several ways. Basically, V2 presets were really only a quick way of applying a particular combination of formats to text. Once you’d applied that preset, there was no easy way of updating every instance of that format dynamically.

V3 styles are much more like the concept you get in Word: text is marked as belonging to a certain Style, and if you decide to alter that style, then Scrivener will update every instance of that style in the document for you. Furthermore, those styles can be carried forward to Compilation where they can be passed through or amended to suit each compilation format.

That’s mainly why you can’t import the old formats — they’re different beasts. But there is a relatively easy way to create new styles from a V2 project: I suggest you test this first on a copy project till you’re happy with the process. As an example, I’m going to use an old preset Heading 1 and convert it to the Style Heading 1.

  1. Select the entire manuscript as a scrivening.

  2. Go to the first example of your old preset Heading 1 and select it.

  3. In the Style Panel (Ctl-s), use the gear icon and choose Select Similar Formatting. Scroll down your scrivening – it should have selected ever single instance of the old V2 Preset Heading 1.

  4. In the Style Panel, is there an existing style called Heading 1? If there is, then right click on the Heading 1 entry in the panel and choose ‘Redefine Paragraph Style from Selection’. If there isn’t a Heading 1 style already defined, then Format > Style > New Style from selection from the main Scrivener menu bar.

  5. In both cases you’ll be taken to a dialogue box. Enter ‘Heading 1’ in the Name box if it’s not already there. Choose a shortcut (for the time being just choose one off the list – I’ll discuss shortcuts in general later). We’re talking about a heading here which is usually a Paragraph style – so choose this from the Formatting dropdown box. You’ll probably want to tick include font family and font-size as well for a paragraph style. You can choose to add a coloured box round the style if you want. Finally choose which style you want to be automatically chosen when you press Enter at the end of Heading 1. Then press OK. If you’ve redefined an existing style, you’ll be warned that every instance of Heading 1 will be updated to the new format. Press OK again. (In the screenshot below I’ve named the old style V2 and the new one V3 just to be clearer – you wouldn’t actually do this!)

You’ve now created a new defined Style (in my case V3 Heading 1) and allocated to all the instances of the old V2 preset. Here I’ve right clicked on V3 Heading 1 in the Style Panel and chosen Select All Text with Paragraph Style – use this to make sure the conversion has been done properly.

All you need to do is repeat it for your other styles. You’ll only ever have to do this once – because once you’ve defined the styles in this project, you can import them to other v3 projects using the Import Styles feature.

Other points:

  1. Don’t create a special style for body text – this will make compilation harder than it should be. The idea is that you only use a style when you want something different from the default – you shouldn’t have a style allocated to every single bit of text. Set your default paragraph formatting in Preferences > Editing > Formatting – it will appear in ‘No Style’ in the Style panel.

  2. Shortcuts. Scrivener allocates cmd-shift-1 to 9 to styles (cmd-0 returns you to ‘No Style’) – you can choose which style gets which shortcut. You can’t add you own shortcuts within Scrivener, but you can of course use the standard Mac System Preferences route to add your own if you want. I don’t bother – I’ve just adapted to using the inbuilt Scrivener shortcuts.

Hope this helps!

I think what I had been doing was

  1. Getting confused by the toggling - so sometimes the shortcut would apply the style, and sometimes it would apply No style (which I thought was an error);
  2. Not ticking 'Save all formatting (When I found that a new style I created was working fine, I replicate all these settings in the problematic one.)

I’ll leave it all here, in case someone else has the same issues.

I’m adding my problem here, as I think it is a Shortcut issue.

I have used Styles and Shortcuts absolutely fine, until a few days ago.
I had a particular Style in all three projects, and tried to replicate the Shortcut in the two projects that did not have it.
It simply stopped working the way I expected it to (and as outlined above.

I select the text: Blue, No style font (Palatino)
Go into Format - Styles - Redefine Style - select the style
I set the Shortcut to Alt/Cmd/8

But when I press Alt/Cmd/8 I get a completely different font (Courier Prime) in black.
The style box above says ‘No style’. (It is not in fact 'No style, it is Courier Prime)
No style is still accurate if I re-attribute that ‘lack of style’ to the text.

If I click the style itself (rather than using the shortcut) it changes to the correct format for the blue Palatino style.

If I select or click on some text that says [the name of the style] in the Styles box, and then use its shortcut, it changes the font to Courier Prime, but keeps the blue colour and the style’s title in the Styles box.

In my original project, where it has worked fine ever since i started using Scrivener, using the style shortcut toggles backwards and forwards between the named style and No Style. In the new project, it doesn’t. In addition, it is just a whole mess, in that when I then manually click No style for the menu, it retains the blue colour of the current style (although it reverts to the No Style font).

I have tried too many things to remedy it to identify what probably caused it, but I have tried various permutations of Paragraph v Save all formatting, and Include font family or not.
It also doesn’t reliably return to No style in the following paragraph, even when None is set (I always set None). In fact, this might be the first problem I identified, before having trouble with the shortcuts, but I’m afraid I can’t remember. (I didn’t realise it was going to be such a ‘thing’, until I subsequently spent two days trying to fix it).

This morning I have tried deleting the style I had problems with, and creating it anew. But I am still having all the problems above.

Scrivener 1 and 2 didn’t have styles, only “presets”. Scrivener 3 has true styles, the difference being that modifying a style changes formatting for everything the style is assigned to.

Find a paragraph you like and define a style based on it. Give it a shortcut. Use that shortcut instead of the one you’re accustomed to using for the associated preset.

You don’t have to use styles or the shortcuts, but styles take the place of presets and are far more powerful, more than Word styles.

Fonts and styles are two different things, and “no style font” is just a confusion.

Part of creating or redefining a style is telling Scrivener whether it’s a character style (a), paragraph style (¶), or both (¶a). Existing styles have those symbols next to them in the Styles panel and in the dialog you mentioned, and the define/redefine dialog includes settings to determine the type.

The Styles panel (ctrl-S) makes it easier to see and work with the styles and their shortcuts.

Again, fonts and styles are two different things. Every character has a font, but they don’t all have styles.

If the box says No style, either you haven’t assigned a style, or worse, you’ve created a style called “No style”, which is not the same thing as “No Style”. Notice the capital letter. It sounds as if you did the 2nd thing.

If a shortcut changes anything, it should assign the style, and if it changes the font family, that means you selected a checkbox or dropdown telling Scrivener to assign the font family (at least) or possibly all formatting to that style.

But if I did this, wouldn’t I have had to go into the Format-Style menu and either have created a new style and called it No style? I definitely haven’t done that.

But this is the crux of the problem.
The shortcut does not assign the style. It assigns something that a) says ‘No style’ (but is not the same as the actual No style attributes everywhere else in the document, and b) allocates a font (Courier Prime) that I have not chosen. I don’t like courier fonts. I would never have chosen it.

Now it is doing something slightly different, in that I have for the millionth time tried to re-define the style as I want it (based on the selected text, formatted as I want it). Now it is keeping the font when I use the shortcut, but not keeping the colour. It just keeps doing its own thing. It doesn’t seem to make any difference what I do. It looks like a pretty simple process, and it always was in the other project:
Type something
Format the text how I want it
Create style
Assign Shortcut

I have just tried this with a new style/shortcut, and it seems OK. It is just not working with the particular style/shortcut. It’s doing my head in.

I don’t know what you did, but I know the styles work.

That’s incomplete, since it doesn’t list the style name.

Very helpful. I know Styles work too. As I said, I have been using them for months, and they are also working fine in my other project.
The problem is that I have a PROBLEM, hence querying it here. Something that ‘works’ is not working as it should. I am trying to identify the cause.

If you want a Zoom session, we can do that.

Zoom me

Type something
Format the text how I want it
Create new style
Assign Shortcut

No thank you. Do you work for Scrivener?

I’ve been retired 21 years. I help people all I can, but it can’t always be done in text messages.