Style For Outline Format

I am fairly new to Scrivener so may be an obvious omission on my part.

I am trying to use a sample outline to create a style that I can apply to some text.

When I save the selection as a style, the indents go away. If I tabe a subitem, it sets two tabs. If I shift tabe then the first sub item is set as expected.

How can I set an outline format using a style that works better?

A style contains the indent setting.
So that can’t be ideal, because you can only set one indent per style.

That leaves you with three options (in order of convenience, my POV) :

1- Use the list feature instead.

. . . . . . .

2- Set the TAB values as you want them for a paragraph, and create or redefine a paragraph formatting or save all formatting style from this paragraph.



. . . . . . .

3- Use one style per indent/level.
…I don’t recommend it so much (use that if there is more purpose to the choice than simply indenting what in the end is simply a list), but here is a template :
→ The only advantage of this over TABS is that tabs don’t work in an Ebook, and that using this multi-styles method, you may have different fonts and whatnot per level.

The good answer might depend on what the outlining is for.

  1. If you are outlining as a development step in structuring your thought and writing – and so the outline is nothing which will be seen in your final output – then you should check out Scrivener’s Outline View mode. Outlining without messing with any sort of styles or tabs etc. Scrivener’s outline tool is a bit unusual, since what is being structured is the constituent documents of the project themselves.

  2. When I do outline structuring within a text document, I use a set of custom defined paragraph styles (Heading 1, Heading 2, etc.) each with its own assigned key command shortcut. What these defined styles do is nothing more than have different amounts of left paragraph-indent. This works well for me.

When I save the selection as a style, the indents go away. If I tab a subitem, it sets two tabs. If I shift tab then the first sub item is set as expected.

It sounds like you might be saving your style as a character style rather than as a paragraph style – which retains tab stops (which you seem to be talking about).

Our maybe the disappearing you mean is when you hit carriage return and want to continue outlining. That would be because you failed to specify a “Next Style” in the style definition dialog box.

Unless your outline line items never line-wrap, your idea of using a single defined style with tab stops will not prove satisfactory for your outlining, because wrapped lines will go back to the left margin setting of the paragraph not the tab stop of the start of that line. (Plus, of course, there is all that tabbing around!)

1 Like

Thank you for the replies.

I love Scrivener for the notes I am writing to use in presentations. I use an outline format for my “points” and then insert resources to refer to.

I could do this in Word but then I lose so many powerful organizational abilities that Scrivener provides.

I think maybe the best compromise may be to have a style that invokes the Outline formating and then just use the tab key for my indents.

I will reply if this solves my use case.

1 Like

Thank you for your replies. So far, none of these stratigies seem to work providing an outline format with selected bullets, font, size and format.

Many of us writers need a proper “Outline” format that is consistant and I feel this is an area that Scrivener could improve.