Styles are driving me mad

I have set my own style, given it a name, selected every sheet in my project and applied the style. The style = Optima 16, 6pt paragraph spacing, NO indent 1.1 line height

All my text is looking good in my style, fantastic.

I hit return at the end of a line I get an indent!!! and my style is not being used. If a style is applied to a sentence or a whole page, if I return at the end of a sentence why does scrivener change the style and indent it. That is so dumb.

It actually isn’t.
There are quite a few circumstances where that’d be wanted.

This being said, select a segment of text to which your style is properly applied. (That looks the way you want it to…)
Then, redefine your style. Format/Style/Redefine style from selection

Make the current style be the next style.

2 Likes

Also note that by the sound of it, you are using that style pretty much everywhere… (?)

That is not quite the right way to go about it.

You should (if that is the case) rather use the default formatting (“no style”).
Styles are intended for segments of text for which the formatting divert from the overall body text’s formatting.

4 Likes

Thanks But i want all of my sheets in the style I mentioned, nothing more. I don’t need any other font or paragraph attribute at all. How can I set it that way

I just want to write. I’ve come from Ulyssess where this problem of text holding on to formatting, or using different formats in the same document just doesn’t happen, you choose a font and a size, thats it. One style and no matter what you do, where text comes from it does not change. In scrivenor Is there not just a simple writing mode, devoid of all this formatting that will emulate this?

Update: I made a couple corrections.

First delete the style, since you’re not wanting the features of a style.

Then set a default format in Preferences. To correct existing text, select documents and use Document▸Convert▸Convert to default formatting. Going forward, the default format should carry over from paragraph to paragraph.

1 Like

Further to @drmajorbob’s and @Vincent_Vincent’s comments, you are struggling mostly because you are trying to bend styles to your will without sufficient regard to how styles are intended to be used.

Rather than repeat all the guidance here (and there is plenty in other threads here and I confirm from experience that using styles as intended works great), re-read section 15.6 of the Scrivener Manual if you wish to learn about styles.

Simplistically, use “No Style” most everywhere, and then use paragraph and character styles by exception. Rely on the compiler to get all the formatting as you want.

2 Likes

If not done already :
(Backup your project first)

  • Go to Project / Project settings and confirm that this option is unchecked :
    image
    Click OK, go back to the text editor.
    . . . . .

  • Select a segment of text that already looks the way you want your text to be formatted.

  • Then with that text being selected in the editor, go in the options :
    (Here, I am assuming that you don’t have other projects with a different default formatting set by you. This next step will set the default formatting for all your projects. If you don’t want that, go back to Project settings (my first screenshot), click the option I highlighted, and rather set the formatting as described below, but there instead of in the options panel.)


    Click that.
    . . . . .

  • Click “OK”, leave the options.

  • Go to Format / Style / Delete style : delete your style.

  • Select all of your documents in the binder.

  • Then Documents / Convert / Text to default formatting
    Leave the popup as it is, hit “OK”.

→ You should be good to go from there. “No style” is now set to the formatting you wanted for all your current and to come documents.

Write a book.

2 Likes