I noticed sometimes my substitutions stop to works in Scrivener. So I have to quit the soft and to open it again.
Somebody else has this problem ?
Is it an OS problem or Scrivener ?

This is definitively a bug. I have it everyday. And sometimes more than once a day.
And each time, I quit and then restart Scrivener.
So… is it a Mac bug or… a Scrivener bug ?
(I precise I’m writing in French)

I think it’s when I add a .
Sometimes, the transformation of this character stops to work. And break all the others substitutions…
It happens quite a lot in fact Around every… 15mns !

Are you using the Mac App Store version? If so there is a known bug with it that can cause spelling and corrections to fail after a time. We don’t actually know what is causing the problem, yet. It was working fine when it was released, so we suspect a subsequent OS X upgrade has created a conflict. In the meanwhile we are aware of two potential solutions. Once is to clear your project’s interface settings, which can be done in the File menu by holding down the Option button. You’ll see the hidden option pop up when you do toggle the Option key. This only helps temporarily, however, so it’s not much better than restarting since you also lose your project’s interface settings.

The other solution is a bit more permanent, and that involves downloading the direct-sale version and running that instead. It has been programmed to detect MAS receipts and unlock itself out of demo mode, so this is a completely legitimate way to run the software. The bad news with that method is that you’ll need to do a little migration to effectively move over, because the MAS version uses its own sandboxed area for preferences that the direct-sale version cannot use (and vice versa). But it’s not too difficult to do, and once you’ve run through the checklist you’ll be fine indefinitely on that score, at that point you’d be just like anyone else that purchased the software directly from us.

Thanks Amber for your answer.
I bought Scrivener on your website (downloaded the trial version and entered the license key), not on the App Store.
So, I don’t know.
I will try the first solution for the moment.
Because I have to send my novel today to my publisher :slight_smile:

Strange, it must not be the same problem then; I doubt the ui settings trick will work. There was an issue with spelling quite a while ago, but this was fixed in the 2.3 update. Have you checked to make sure you are running the latest version of Scrivener (there is a menu command for that in the main Scrivener application menu)?

Sorry for the delay of my answer.
I’m on the last version : 2.4.
Substitutions worked until today with the tip you gave me… But stopped to work today - with the version 2.4.

There seems to be an ongoing problem where substitutions and spell-checking just stops working for some users, and it’s been happening since Lion, but we’re still none-the-wiser on what is causing it. All of these things are handled internally by Apple’s text system, with the code in Scrivener for this limited to only turning these features on or off. Moreover, I have done tests with users to ensure that the features are turned on in Scrivener when they are not working for them (if the features are ticked in Scrivener’s Edit > Spelling menu or in the preferences, then the features are turned on).

First, tt’s definitely worth trying to clear out your interface settings again. Do you have any similar problems in TextEdit at all?

All the best,

I have a suspicion that the spelling engine in general has lost overall reliability in the last few OS X updates. Often I hear reports of this happening not only in Scrivener, but in Mail and other Cocoa based software. It’s just that writers living in their writing software are naturally going to pick up on any sporadic failures more quickly than someone that writes a Tweet now and then, or at the most an e-mail to the folks. There may be some trigger in Scrivener specifically that is increasing the chances of it happening, but I do know there are widespread problems right now for those who are adopting Apple updates more rapidly than others.

Thanks for your answers.
I just tried in OpenOffice.
And problem is the same…
It’s possibly linked to Lion.

Hmm, that’s interesting considering that OpenOffice’s text engine is not in any way related to Apple’s. As far as I know it cannot take advantage of Lion Text & Language substitutions. Is this what you are referring to, or are you using a third party software like Typinator?

Ah, do you mean OpenOffice doesn’t use Text & Language substitutions ?
So it’s probably for that it doesn’t work ^^
I use only Scrivener - and OppenOffice to check exports.
But substations work at this moment so I can’t try in TextEdit for example.
As soon it stops to work, I try!

Well it may not be a global failure, so a better test would be to spend all day writing in TextEdit as you would with Scrivener (basically, just copy and paste whatever you need to work on out of Scrivener into a TextEdit window, and work there instead of Scrivener’s editor. After a few hours you should get some data on whether spell checking and substitutions are breaking in TextEdit as well. I don’t think waiting for the problem to appear in Scrivener, and then switching over to TextEdit to type a few words is going to provide us with much data.

Yes, I can understand that. But I’m working on a big script, and TextEdit is not the best for that. Unfortunately, I don’t think I can do the try for the moment.

By the way, the problem doesn’t appear after a few hours. It can take weeks… One month sometimes. The last time was when I updated Scrivener (the day or the day after the release). Since that, it works…

Ah, yeah, with scriptwriting that puts TextEdit out of the picture, and I can’t think of any scriptwriting software that uses the same Cocoa text engine we do, that is free and easy to test with. Hopefully as we continue to gather data we’ll get a bead on what the problem is. Are the substitutions even impacting your own character names, and the INT./EXT. stuff, or is just the Text & Language panel stuff?

I think it’s only Text & Language. I didn’t notice anything about other stuff.