Sudden "Not able to save" warnings

Yesterday, when I started writing my program suddenly gave me “not able to save” warnings when it tried to auto-save. At first I thought the problem was with my new project…that maybe something freaked out or had been corrupted. But, the issue is following me across ALL projects. The problem continued even when I tried to create a new project!

This is what the warning says:

Could not save project notes.
Failed to open project notes file (with file path).
Error: The process cannot access the file because it is being used by another process.

Also getting this warning (later in day):

Could not save binder.
Error: Could not open binder file.
Identity: ‘Scrivener:Folder:Plain’
Location: file path

The problem is that I do not know how it is being used by another process or where to find that out. Was there some Windows update that is freaking out the program or is Scrivener holding itself hostage? NOTE: Warning does not seem to affect the actual ability to save the writing.

If anyone can help, I’d be so happy. :smiley: Thanks!

The 1.6 Scrivener update introduced some new error checking to help catch fringe cases where documents can’t save properly (e.g. due to changed permissions on a file), throwing a warning and giving the user a chance to copy the text out and ensure it’s saved safely elsewhere. We’ve had a few cases like yours reported since then, where the auto-save isn’t able to catch a particular document because it’s already locked by another process, and we’re working to discover what’s causing this on these systems and how to resolve it. If you’re willing, we would greatly appreciate your taking the time to follow the steps below to install the Windows Sysinternals tool Process Monitor and set it up to log events on your Scrivener project as you trigger the save error. That log and a copy of the project used to trigger the error should give us some additional clues.

If you’re using an actual project for testing this, ensure you have a recent backup before beginning. If you’re reliably getting the error on new projects as it sounds, just go ahead and create a sample project to use for this. The steps below assume you’re using Windows 7 and I think should work for Vista and up; XP may be slightly different, so let me know if you need modified instructions for that system.

After you’ve gone through this, assuming the manual save works in the steps below, I suggest changing Scrivener’s auto-save interval in the General tab of Tools > Options to 8 or 10 seconds, rather than 2. By triggering auto-save less often, you’re less likely to run into the problem of the file being locked, so you shouldn’t be getting the error message all the time. I do suggest however that you keep good backups and run manual save periodically–ideally, you’ll want to have a manual or auto-save before switching documents in the editor, to ensure you don’t run into a problem of the document text not saving for that particular file. The error message should give you the title of the document that’s not saving, though, so you can keep an eye on that one particularly. If it’s just the Project Notes, you can ignore it unless you’re actually adding text into the project notes–in that case, I’d do a manual save before switching to make sure the text of the notes does save, or copy and paste the notes to another program before closing Scrivener to ensure you have a copy.

Assuming you’ve never before had an issue where text appears not to have saved in Scrivener, I think you’re probably safe for most files–the error is reporting on a problem that has probably been occurring for some time, and it’s just now that we’re able to catch it. Presumably then you’ve been saving successfully for a while and most of your files are not at risk.

We’re working to resolve this as quickly as possible, so any extra information you can give us will be a big help!

  1. Download and install Process Monitor from here: To run this you will need administrator access.

  2. Before beginning Process Monitor, close all open programs and go to your Windows Start menu, type in “msconfig” and hit Enter to open the system configuration options. (Depending on your UAC settings, you may need to press Ctrl+Shift+Enter rather than Enter to run this as an administrator.)

  3. In the General tab, choose Selective Startup and deselect “Load startup items”, then click OK. At the prompt, please restart the computer.

  4. Open the Windows clock and keep the time visible while you proceed with the remaining steps, so you can make note of the time in seconds (as near as possible) when indicated. If the clock is visible in your taskbar, click it and choose “Change date and time settings” to open it as a window; otherwise, enter “date” into the search field of the Windows start menu and select “Date and time” from the list of Control Panel results.

  5. Launch Process Monitor

  6. In Process Monitor, deselect File > Capture Events

  7. Select Edit > Clear Display

  8. Go to Options > Select Columns and enable the following, as
    shown in the attached image (ProcMonColumns):
    Application Details:

  • Process Name
  • Image Path
  • Command Line
    Event Details:
  • Operation
  • Time of Day
  • Path
  • Detail
  • Result
  • Duration
    Process Management
  • Process ID
  • Parent PID
  1. Select Filter > Filter… to create a new filter. From the first drop-down menu on the left, select “Path”. From the second select “begins with”. In the text field, enter the path to your Scrivener project’s .scriv folder. You can copy this from Windows Explorer by navigating there to your project, e.g. MyNovel.scriv, opening that folder so you see the “project” .scrivx file (what you’d double-click on to open it in Scrivener), then clicking into the blank area of the address bar at the top of the file browser. This should show the file path in the form C:\Users\USERNAME\Path\to\project.scriv; copy that and paste it into the field in the Process Monitor Filter, as shown in the attached image (ProcMonFilter).

  2. Leave the final drop-down option in the filter to “Include”, then click “Add” so the new filter item appears at the top of the list below and click “OK” to close the window.

  3. Select File > Capture Events to begin capturing events (you’ll see the numbers counting in the lower left of the Process Monitor window, though nothing will appear immediately in the main area).

  4. Open your project in Scrivener and note down the time, as near the second as possible. (Note when you click to open Scrivener, rather than when the project is fully loaded.)

  5. Work in the project until you trigger the error message that the file cannot be saved because it is in use by another process. Note down the time the error message appears and the title of the file indicated in the error message.

  6. Click OK to close the error message dialog

  7. Make a small edit the document indicated in the error message as the one that could not be saved. This may be the document already open in the editor, another you recently edited, or the project notes.

  8. Before auto-save runs, manually save the project via Ctrl+S or File > Save. Note down the time you perform the save, as near to the second as possible, and if the file saves successfully or if the error message recurs.

  9. Return to the Process Monitor window and deselect File > Capture Events.

  10. Select File > Save and configure the save options. Under Events to Save, select “Events displayed using current filter” and check “Also include profiling events”. Select Comma-Separated Values (CSV) as the format. You will probably also want to change the location of the save to somewhere more easily accessible. Save the file and exit Process Monitor.

  11. In Scrivener, copy the text from the document triggering the save error and paste it into another program to save it, in case the save in Scrivener failed. Then close and reopen the project to determine if the text did save correctly in the document.

Please either attach the CSV file and a zipped copy of the Scrivener Project used to create it to your reply here or send it to AT literatureandlatte DOT com with a reference to this thread. You can use File > Back Up > Back Up To… from within the Scrivener project to create a zipped backup to attach along with the CSV file. Please also include all the times you noted down for when Scrivener was started, the error occurred, and when you manually saved the project, and let us know if the manual save did successfully save the file (i.e. whether it triggered the error message and whether the text you added during the session was still in the document after closing and reopening the project).

To reset to your regular startup options, type “msconfig” in the Windows start menu and return to the system configuration options, then select “Normal startup” and click OK. The settings will take effect the next time you restart Windows.

Thank you!

I am having the same problem as the first poster. I won’t be able to run through those steps in a reasonable amount of time this week so I’ll be manually saving and keeping my fingers crossed. I’ll see if I can get it to save every 8 to 10 seconds as you suggested.

Please let me know if and when there is a patch or some other quick fix for this distracting (and potential project loss scary) problem.

If the warning message is just about the Project Notes not being able to save, you shouldn’t have any need to worry; what you’ll want to watch for is a case where a document title from your binder is given as the file that could not save, and in that case, use a manual save. I believe at this point everyone who has reported this error (there’s only a handful) have not all been able to successfully manually save after the error and no one has lost any work. Given what we do know about it, the file lock in most cases with this warning (that the file is in use by another process) is not persistent, so when a save fails at one time it will work properly later. Adjusting the auto-save interval should greatly reduce the frequency of the warning, since by saving less often you’re less likely to be trying to save at the moment that the file is locked by something else–for some people, it’s made the problem almost completely disappear. Just remember that the interval is seconds of inactivity, so Scrivener will only auto-save your work when you pause for 8 or 10 seconds–if you’re typing at full speed for a long while, you may want to hit Ctrl+S to force a save now and then.

If you enable the check for updates in the General tab of Tools > Options, you’ll be notified when we have a new version available.


now I have this Problem too, but I am using MacOS 11.1 and Scrivener 3.2.2

Is there a solution ahead?


This is the Windows forum. This should be posted in the equivalent Mac forum.