Superscript appears awkward

Hi guys,

I have been using Scrivener for a few years now. I was wondering if I’m missing something with superscripts. I use superscripts of various kinds. But whenever I try to add a superscript MANUALLY it makes its font big and awkward, with a higher baseline.

Why is this happening? Is there any fix?

Yes, it can be a bit awkward. It’s a limitation of the Apple Text engine that Scrivener uses. The main issue is that superscript changes the baseline but does not reduce the font size, so the spacing of the line is then changed.

What you can do is create a character style for Superscript. Format some text with the baseline and size that you want, select it and then go to Format>Style>New Style from Selection. In the Formatting menu choose Save character attributes, and give the style a name and a shortcut. Then click OK.

You should now be able to invoke the shortcut to make text superscript with the correct sizing that you set. See section 15.6 of the manual (in the help menu) for more info on styles.

Ok. I will try that. However, when I compile to PDF, it’s fine. But if I compile to Word, the superscripts retain their odd size. I wonder if the solution you have shared will resolve the issue of the odd size in Word.

In theory it should do. You might have to tweak a couple of compile settings.