Switching user accounts

Hi there,

Due to keychain login issues I am creating a new account on my Mac for me to use. I have registered Scrivener again and got it on my new account, but I am wondering how to move my old project from my old account to the new one. I tried putting the Scrivener documents into the Shared folder and then dropping it into my Documents folder on my new account, but when I tried to open my project I got the message that the document was “read-only” . Where do I change my project from “read-only” to 'read and write" ? Or is that indeed what I need to do?




In the Finder ctrl-click on the file and “Get Info”, then under “Sharing and Permissions” at the bottom of the Info panel change it so that your new account has read and write permissions. If you moved it across from the other account, by default the other account will have write permissions but your new account will not.

Hope that helps.

All the best,

I have checked both accounts and they both have read and write permission. But I still am having the same problem. Is it something to do with how I am moving it over? I have taken the Scrivener file from the old account (the .scriv file) and put it into the Shared folder, opened the new account, dragged it out of the folder onto the desk top, and tried to open it. All I get is the message that Scrivener cannot open the file as it is read-only.

Any further wisdom?

How comfy are you in the terminal?

cd Desktop
sudo chown -R $USER <proj>.scriv

That should fix it.

Hmmm…you’re going to have to expand on that a LOT for me to understand it. My level of comfort for that kind of stuff on a scale of 1 to 10 resides somewhere in the negative 10 range. :cry: But I’m willing to take the plunge as long as I won’t completely muck everything up by doing so. I’ll need some pretty clear step by step instructions.


I am assuming that when you said “dragged it to my desktop” you mean that you have the project file sitting there next to your HD icon. If this is not true stop here and tell us where the file is. First thing we need to know is the name of your scrivener project. For the sake of this example we will pretend that the file is “My Project”.

Here is where we have a few things to get technical about. Spaces are special and need to be escaped. To escape a space you put \ in front of is. When we type the file in the following we will need to make sure we escape the spaces like this

My\ Project
My\ longer\ project

If that is confusing don’t worry about it. Tell me the name of the file and I can show you exactly what you will need to type.

Goto applications folder, open the utilities folder and find Terminal. Double click it. This will open a window with some text in it. You should notice a $ at the end of the last line. This means that terminal is ready for you to type commands (everything we are going to do is quick and the $ should show up really quick).

Now type the following (remember to replace “My\ Project” with the correctly escaped name of your project)

cd Desktop
sudo chown -R $USER My\ Project.scriv

There will be extra stuff that the terminal adds, but you only need to type the lines above. We may need to type a few extra lines, but let’s start here.

Let me know if this gets it for you.

I’m having the same problem. I need to use 2 user accounts, but access the same Scrivener projects at will, from either.

Both are Administrator accounts.

As the other poster reported, setting permissions to R/W for both user accounts does not help.

I managed to get Scrivener to open the .scriv project by setting it, and its enclosing folder(s) to give Administrators R/W access. I had already set my two users to identical R/W permissions.

So . . . yes, I can open.

But no, I can’t save.

The project and its folders are my working drive (physically distinct from the system drive) – one that belongs to everybody (“shared”) and with all users (including the Administrators group) individually having R/W permissions.

This problem does NOT occur with Word documents, provided I have set the permissions as I’ve described.

Using the Terminal method gives no better results – yes, I can open. No, I can’t save.

It’s important to me to be able to open (and save) the same .scriv project without regard to which user I’m logged in as.

The only thing I haven’t done is a shutdown/reboot. I’ll post this, and then try that. Of course I’ve logged in and out of both accounts several times.

Any ideas?


The sciv file is a package (a fancy directory) and when you are setting the perms you are not getting all the files. Word “docs” are complex, monolithic, self contained files.

This is the “more lines” part that I noted earlier.

sudo chmod -R g+w My\ Project.scriv

If you still get errors follow that with

sudo chmod -R o+w My\ Project.scriv

Much of this is a brute force method that should really be avoided. Problem is that to avoid this you need to set all the accounts up “in the beginning”. Since we are working with preexisting accounts and docs this is simply the easiest way to deal with the problem.

Thanks, Jaysen. I had forgotten that a Scrivener project is actually a folder, so of course the whole thing was more complex than fiddling with a single Word document.

I did muddle through, taking the project to one desktop, doing the terminal actions, and moving it back. Then, when logging in as the other user, all I had to do was to give the second user permission, and all was well.

Terminal! I cut my computing teeth on DEC RT11, RSX, and VMS. But it’s been more than a year since I did any VMS terminal work, and I never had any occasion to learn *nix commands – they remain obscure to me.

If I may ask – whereabouts are you in Upstate NY? I am south of Buffalo.

Thanks again.


One of the prime reasons for Mac was the BSD underpinnings. Being a *nix guy (cut my teeth on 0.9 Linux kernel and then DEC Unix on an A64) I find the ability to actually “fix” things (like cups, apache, etc) very reassuring. Not to mention I get to use all my favorite utilities.

Biggest thing to remember is that OSX actually uses real ACL. If you create a file under one user then you will need to set the file to a common group and then set the group write bits. If there is no common group … well then we get to set the global write bits (which is a no-no normally).

But who cares? It works right?

Jaysen - I don’t want to hijack writergal’s thread, but I have more questions.

Assuming that “administrators” is a group for ACL purposes, then why didn’t setting the permissions (via Get Info) to allow r/w for administrators solve the issue? I would think that administrators was a common group. The “apply to enclosed items” choice didn’t appear. Maybe that’s why.

Finally – I have an Alphaserver and an Alphastation (VMS) sitting in a closet, unused and never to be used again. These are mid-nineties models. 300/266? I forget. Point is that if you want to fool around with the Alpha architecture and, say, Linux, one or both are yours for the asking, as in free. Also I have a bunch of VT510/520s, and 90L+ terminal servers. All these can be yours, free!

Sorry, again, for the hijacking, but if there’s a PM option on this forum, I’ve missed it.

Sorry. There’s the PM icon right there – too obvious for me.

Hijacking is so common in these parts that folks might be insulted it one of the +3 doesn’t abscond with a thread for nefarious reasons. So don’t worry about it.

Over simplified two part answer: the finder did not apply the permissions all the way through the package. I have seen that changing perms on a package only changes the top level (the dir). This is particularly true if the owner of the package is not the person changing the perms. The other point is that files should be created using your default group which should [b]not[/] be admin, but a group that matches your name. Open terminal again and issue the command: id. The gid is the default group that will be used when a file is created.

A more secure method for you to have used might have been

sudo chgrp -R admin My\ Project.scriv
sudo chmod =R g+w My\ Project.scriv

This would have left the primary owner in tact while setting group ownership to the shared admin group, followed by allowing all members of the admin group to write files.

Hope that makes sense.

(wailing in the background)… :frowning: okay I’m totally freaked out about all of the above!! I think the best thing to do in my case will just have to keep my other account going and just use it for my writing project. I’m really not comfortable with all that computer programming stuff.

Thanks so much for your attempts at help, but it’s just too big a mountain for me to climb. Too afraid of the cliffs!!