Sync issue with Dropbox only on one device

Hi - For years everything was working fine syncing my files through Dropbox and accessing them from both a desktop and a Macbook Air. Out of the blue a couple of months ago I started getting an error message on the laptop that said a .scriv file couldn’t be opened because it was of “an older format but no binder.scriveproj file could be found etc…” At first it seemed to just be happening with files I hadn’t opened for a while but today I noticed a recent file that was working even after I started seeing this error message is now giving me the same error (it has been about six weeks since I last tried to open this file). On the desktop when I open an older file it just asks if I want to update it and then works fine.

Things I have tried:

  • Uninstalled and reinstalled Dropbox on the laptop, including the advanced uninstall. (I did notice that all the files have a modified date of today at the time I reinstalled, which is different from the dates shown on my desktop.)
  • I thought the issue may be that I only sync selected folders on the laptop (even though it’s worked for years), so I setup the same sync settings on my desktop. Works fine. I even tried updating an old file on the desktop, waiting for it to sync and then opening the updated file on the laptop but got the same error message.
  • Uninstalled and reinstalled Scrivener. However when I reinstalled my license was still activated which makes me think it wasn’t a complete uninstall. Any file I open shows the same error message.

I can’t tell if this is a Dropbox, Scrivener or Macbook Air issue, any thoughts would be appreciated.

Things to check:

  1. Is your MacOS set to “smartcloud” (or whatever they’re calling it) — i.e. removing unused/little used files from your hard drive and making them available from the cloud on demand? Scrivener expects the constituent files inside the Scrivener project bundle to be resident on your hard drive. You need to turn that MacOS setting off.

  2. Is your installation of Dropbox set to store the things in your Dropbox folder as Remote Only (i.e. to store them on the dbx server only and make them available in demand)? You need to turn that option off (or exempt your Dbx/apps/Scrivener folder.

  3. Another possibility is just trying to open projects before Dropbox has finished syncing your projects. But you are a practiced hand at this, so I am guessing that’s not it.

Just for sport, I am betting it’s going to be (1). [Edit: dmBob’s post is making me think I already lost my little wager!]

A couple of months ago, Dropbox changed so that files are online only by default, which causes exactly the problem you’re having. Right-click on the folder where your projects are placed, and change the setting.

Thanks so much for the suggestions. The Dropbox settings are the same on my desktop so I don’t think it can be the online-only thing. Also this is a folder I’ve selected to sync to my hard drive so it was not set up as online only. (I am trying the ‘make available offline’ option to see if that helps, but again doesn’t seem to be an issue on the desktop…) I google the MacOS Smartcloud option but couldn’t find anything, any idea where I could look for those settings? Thanks!
EDIT: I’m also syncing through Dropbox, would iCloud settings even affect that?
UPDATE: Changing the Dropbox folder to “Make available offline” seems to have worked, but still a mystery because I don’t have that setting on on the desktop. But changes on the laptop do sync to the desktop so that’s all I need. So not a clear winner for the drmajor but he came close! Thanks again.

You’d better check again.

You’d better turn it on, then. It’s not surprising for Dropbox to keep files local on one machine and not on the other, if you give it a choice.

1 Like

Actually, that is pretty much a clear win for dmBob. The fact that exempting your project file or folder (aka ‘make available offline’) fixed the problem almost surely means you have Dropbox’s remote-only option switched ON. (And maybe your desktop is not a Mac?)

Someone else is probably more up on this, but: You may have to go to your account at (instead of just looking at the settings avail in the Dropbox app on your computer) and get into the Settings there to shut it off. At least that is what I think I am reading on Dbx’s help pages.

1 Like

I checked my desktop (also a Mac) and the folder in question is NOT set to “make available offline” but is set to selectively sync (as is the laptop). So while making the laptop folder available offline solved the problem it still feels unresolved.

I did check the settings on and there are more than are shown in the app. However the “Online only files on Mac” setting was set to Off. There is another setting “Dropbox system extension / Allows Dropbox to store files as online-only to save hard drive space” that is set to On but I get this warning if I try to turn it off: " Remove Dropbox system extension? The system extension will be uninstalled and you’ll be signed out of Dropbox on all devices. When you sign back in, you can choose what folders to download from You will no longer be able to make files online-only." This sounds to me like I can’t use selective sync which I need because the laptop doesn’t have enough disk space to store my entire Dropbox drive. There have been notices from Dropbox that some apps are having trouble opening online-only files but a) the files weren’t online-only but selectively synced and b) Dropbox says the files should still be able to be opened by double clicking them in the finder which was not the case for me.

At least I can use my laptop for now but still wondering what’s going on. Thanks for your help!

I triple checked, the settings are different on the desktop and laptop. But good point about turning it on, I will do that. Thanks.

A Scrivener project specifically is a folder, with sub-folders and potentially hundreds of component files. The thing you see in Finder is only the top-level folder, and so double-clicking won’t necessarily trigger a download of all the component files.

We do not recommend enabling any form of “selective sync” or “online only” storage with respect to Scrivener projects.

If iCloud is given access to the location containing your Dropbox folder, yes. I have seen cases where all Dropbox settings were fine but iCloud was selectively syncing a project so that neither Scrivener nor Dropbox had access to a complete copy.

@summerdress, put all your Scrivener projects in a single subfolder somewhere in your Dropbox folder, then exempt the whole folder from being online-only. Pretty sure you can exempt a whole folder (unless my mind is playing tricks on me again.) That would solve your problem as far as Scrivener is concerned.


Oh, and buy a bigger hard drive for your desktop? :wink:

1 Like

FWIW, every recent case of this error message that I have seen has been due to some variation of this problem.

Does the Dropbox API have a call Scrivener can use to detect if folder(s) is set for offline and if so alert the user with some sort of message to explain the problem and fix?


Eek. What setting should I be looking for in iCloud? Thanks.

Thanks, that is what I had done, all projects in one folder that I synced to store locally on both machines. Making them available offline seems to be the extra step I needed to take, at least on the laptop. (My desktop does have enough space to store my entire Dropbox folder, the laptop does not which is why I was using selective sync. Not easy to expand storage on that machine as it’s an Air with limited ports.)

1 Like

These are the relevant settings, online-only is off. The other setting seems to force a complete download of Dropbox to my laptop which again is not possible.

This is beyond my tech skills >< but thank you

sorry. thought i was replying to @kewms on this.

See the top screenshot in this post:
iOS/Dropbox not working no matter what I do - #6 by scarlock