Sync with external folder is not importing external files

I set up scrivener (Windows, v to watch a folder on my local drive and to import new files in that folder into a folder in my binder called Transcripts.

However, scrivener does not import any file (neither rtf nor txt files when I place them into that folder. It does import them, when I put them into the draft folder, but then it puts them into the draft folder in the binder, and not into the transcript folder (which is a sub-folder of the draft folder).

If I remember correctly (haven’t used this since iOS Scrivener was released, so I could be wrong) “Sync with external folder” requires that you first set it up correctly and you can then edit and add new documents into the Draft folder. But the stuff in the external folder isn’t organized hierarchically like the binder. It’s just a flat list of files, so you can’t change the hierarchy of the binder or add sub-documents to subfolders in an easy way.

Do you mean your “real” draft folder or its copy in the the external folder? I guess it’s better not to edit or add files in the “real” draft folder. And, yes, I also believe that when you add or edit something in the external Draft folder, scrivener is supposed to pick that up as soon as you press “sync external folder”.

But I also believe that files that I add to the external folder (not the draft folder located within it) are supposed to be imported into scrivener. More specifically, those files are supposed to end up in the Binder folder specified for precisely that purpose in the setting External Folder sync settings.

However, none of the files that I add to the external Draft folder are added to that specified folder (they just end up at the bottom of the Draft folder), And none of the rtf or txt files I add to the external folder are imported into scrivener at all.

I’m familiar with how this works on Mac, and there you must add files to the “draft” folder WITHIN the external folder if you want them to be added to Scrivener.

Hope this helps.

The external sync folder contains a folder named Draft which holds a flat list of all the documents in the Draft section of the Binder. If you add a file to that folder it will be imported to the Draft section of the Binder in Scrivener, but as far as I remember you can’t decide where it ends up in the Binder, i.e. it will always end up at the bottom.

If you look at the contents of the external sync folder all the files are numbered (at least they were when I used this) and they also have a symbol that tells Scrivener if a document is a subdocument or not. How could you enter a new file in that list without screwing up the numbers?

The “Sync with external folder” was meant as a possibility to edit individual documents on a mobile phone or iPad before there was an iOS version of Scrivener, not as a standalone application to edit the Binder itself. At least that’s the way I always perceived it.

Well, the manual perceives it differently (section 13.1 Synchronised Folders). Here is what it says on p 126:

So thanks for making me find the answer to my question (underlined). Apparently I didn’t read carefully enough the first time and tried to use common sense (which obviously didn’t work).

The reason it didn’t work (in case the developers want to make this great feature more intuitive) is that when there is a distinction between internal (already existing) documents and external (to be imported documents) and there are folders created by scrivener inside that watched folder, then the obvious assumption is that the internal documents will be in those folders and the the external documents will be outside these folders (but inside the watched folder, of course). The fact that the user is telling scrivener to watch folder A also conveys an idea that scrivener will actually watch folder A (whereas it is actually watching 2-3 subfolders in folder A).

The best way of fixing this would be to simply import also those files that are in the watched folder outside the Notes folder. The easiest solution would probably be to change the text in the “Sync with External Folder” modal under “Import”. Currently it says “Import new non-Draft items into:” If it instead said “Import new items in Notes folder into:”

And while I’m at it I might aswell mention that I find the option “Sync all other text documents in the project” misleading because if you turn it on, it still does not sync synopses (which clearly are text documents). But instead of changing the UI here, why can’t synopses just be included?