tab and return not working in script format


I’m dropbox syncing two comic scripts between my mac and ios ( on iphone 7), They’re using the comic format that came with scrivener 2. It used to work fine, but the latest round of iOS updates broke the script writing format: the tab and return key aren’t switching between script elements anymore. E.G, if I press tab on an empty line in the panel description, it just indents instead of going to character name.

Not all are broken: Return on dialogue still brings me back to panel description, and tab on character name gets me the parantheses after the name, but that’s pretty much all that’s left.

Figuring that it might be the format itself broken, I made a new file on iOS and applied the default screenplay format to it - there the tab key and return keys are not working as expected either, Return only keeps you in the same script element (e.g. character name stays character name on pressing return) and tab doesn’t seem to work at all.

How do I fix that?

This bug slows down scriptwriting so much, it renders Scrivener useless for me. I now have to manually pick the script element every time I start a new line - which means I’d be better off just taking my projects to evernote and do the formatting manually.

Google hasn’t been a help, it only returned articles written in 2012 - 1014.

i’ve found this old topic by doing a research on google. I have the same problem with the ios version of scrivener.
When in ScriptMode, the tab key seems to be doing the same thing as the return key. It’s very annoying to have to, everytime you need to change the scripts elements, drop your external keyboard and change the element with your finger.
Is this problem not occuring to everybody ?

In normal mode (non script) the tab key works just fine !

How did you go? I had the same error

I’m also having the same issue on Windows Beta – and I’m not sure whether it’s just not supported yet in this beta version, or if it’s a bug?

I double checked that FORMAT --> SCRIPTWRITING --> SCRIPT SETTINGS… had all the “Allow tabs” checkboxes to OFF in the “Tab/Return” sections for each element. In other words, when “Allow tabs” is off, it uses the custom behavior instead of normal tabs. Anyone having issues could check this to make sure they have those boxes unchecked.

Anway, regardless of the state of those boxes, I get no special behaviors for TAB or RETURN, which makes this very tedious to write in compared to Final Draft. Hoping to have this resolved soon!

If you want any attention paid to this, it needs to be in the Windows Beta Testing forum, not in the iOS forum.

How did you go? I presented a similar problem but could not solve it