Tab indents disappearing in compiled Wordx

Hi there!

I’m trying to compile the first version of my book and my tabs/indents seem to go haywire.
I’ve tried everything me and Google could think of, but to no avail.
The strange thing is, the compiled Wordx does recognize some tabs/indents, but ignores a lot of other ones. I’ve looked into the text and all the enters are proper paragraph enters, so that can’t be the problem.
It also seems to eat away most blank lines, and discards the paragraph returns in those.

Does anyone know what to do?

Thanks very much for your help,

Welcome @Brankele.

First question: Are you on Windows or MacOS, and which version of Scrivener?

Second question: Are you using tabs to indent the first lines of paragraphs, and if so, why?

Third question: have you given some paragraphs a style, while other paragraphs are “No style”

As this is your first post, you aren’t going to be able to post screenshots immediately (spam protection!) but we might need to know more about your section types, section layouts and compile settings to be able to help further.

:smile: Mark

Hi Mark,

Thanks for your reply!

  1. I’m using MacOs Big Sur 11.5.2. and Scrivener 3.2.3.

  2. I’m not using tabs to indent the first lines. I’ve also ticked the boxes that say ‘remove tabs from first lines and after empty lines’.

  3. I did yes. And when I found out that that might be the problem, I tried selecting all the text in one chapter and gave it ‘no style’. That didn’t solve the problem unfortunately. Miraculously, there is one subchapter where the tabs do remain, but in all the other ones they don’t…

It might have something to do with the returns, which seem to get lost in the compiled format. Blank lines also get eaten, and my bullet lists are also returned as regular running texts. So maybe Scrivener doesn’t recognize my returns or something?

Thanks so much for helping me out!


Welcome to the forums, Brankele!

  1. If I may: if you are not typing tab characters to get first line indent, and your concern is not with the tab-stop setting of your paragraphs, you should really stop saying ‘tabs’ in the discussion — for clarity. By your own report there is no “tab indenting” in your text! ¶ So, we might ask, when you type a new paragraph where is that untyped paragraph indent coming from?! Answer: your default paragraph format (global or for this project at least) is set to put in a first-line indent for you. BUT that Scrivener default paragraph format setting is only for sure in charge of how no-style paragraphs appear in the editor pane. The look of body text paragraphs in your compiled output is in the hands of your chosen Compile format — which might be giving very different instructions.

  2. You might be expecting your compiled output to look however things look in the editor pane, but that is not really how Scrivener works. Your compile format’s settings are pretty much in charge of everything about how your compiled output looks — and very directly in charge of how your regular body paragraphs (no-style) look — including whether first lines of paragraphs get indented. ((Full disclosure: It is possible to set your compile to compile elements of your draft ‘as-is’ — which would be the closest you would get to output like the Editor appearance.But we have no reason yet to think you have done this or would want to.))

  3. Are you using double carriage returns between paragraphs? It is standard operating procedure for typeset text to not indent first lines that follow blank space (empty lines). There is a checkbox in your compile settings to toggle that off/on. It is probably on and may explain your mystery, because then your double carriage returns are telling Scriv not to indent the ensuing paragraph each time.

  4. There is also a setting in compile to remove empty lines. Wonder if that is on.

  5. For the one miracle document where the first line indents remain, check to see if things are different in regard to whether i) the indents are there in that doc because of actual typed tab characters, or ii) you did not type blank lines between paragraphs there, or iii) those paragraphs in that doc have a defined paragraph Style assigned to them, or iv) that document has a different section type assigned to it than the trouble docs do.

  6. I have my default paragraph in Scrivener set to a 12pt font (I am of the Courier school of composition) with 1.1 linespacing, NO first line indent, but with 12pts of space-after (aka paragraph spacing). So, in the Editor all my paragraphs are nicely automatically separated out by some vertical space (and hence indenting would be typographical anathema.) But I have my usual Compile format set to make my no-style paragraphs have a standard first-line indent and 0pts of space-after (and set in a nice bookish font). So my compiled output looks like typical typeset text you see in books. Highly recommended.

  7. Never use first-line indent and spacing between paragraphs.

1 Like

Hi gr, thanks for your help!

  1. Ah thanks for specifying! And I also just realised I misread the first question of the first reply! I thought it was about the first line of a (new) section, in which I don’t type a tab character. However, in all the following paragraphs I do type a tab character! So in invisibility mode, you see a right-pointed arrow on the left side of the sentence. And as for the why-question: because I like how my document looks that way, it’s easier to structure, both visibly and logically. So I guess I’m still talking about the tab indenting, sorry… And it seems like in my compile settings I’ve managed to have it erase all my carriage returns and tab characters.

  2. No I don’t :slight_smile: I know the compile function works that way. The only reason why I’d like to compile ‘as-is’ is because I can’t seem to find a way to indent the paragraphs properly and still keep some words in italics, as they’re all turned to normal text as I have to toggle the ‘override formatting in text’ box (but that’s another question). But otherwise I’m perfectly fine with constructing the formatting settings when compiling.

  3. Nope. I only use double carriage returns between different sections within one section, if I’m summarising or treating a different subject for example. (I have toggled on the box ‘remove indent on first lines after blank line’, by the way.) In those cases there’s an empty line when reading in Scrivener, but…

3… maybe I’ve mistakenly toggled on that ‘remove empty lines’ box! Where can I find that? I’ve tried toggling on/off the ‘Separator before/after section: empty line’ in the ‘Separator’ section of the compile settings, but to no avail. Or is there even a ‘remove single returns’ box? Given that all my bullet lists appear as running text, that seems to be happening as well.

  1. With the mystery section I still haven’t found what’s different. It’s labelled as a section, the invisibility characters look the same (I’ve typed tab characters), all paragraphs are labelled as ‘no style’ and yet it does yield the proper indents whereas the other sections don’t…

  2. That’s a good recommendation, thanks!


I think I’ve found a (maybe not the) solution! When untoggling the ‘convert multimarkdown to rich text’ box, it seems to go a lot better! The tabs are indented correctly. Except for the first lines, which are now indented even though I’ve toggled the box that says ‘remove indent for first lines and after an empty line’. But that’s definitely a lesser evil!

Could it be that Markdown-convertion? Or did I accidentally do something else…?


Yes! Found it! Took a while, but everything seems to be solved now!
I think the convert markdown-box was one part of the issue, and the fact that I’d created indents in the compile setting using the arrows and hyphens in the ruler, was the other.
The text now also returns the proper italics or bolds when needed, so all the solutions came at the same time.

Thanks so much for your help!

In Markdown a tabbed line indicates a verbatim or code line. This is what three paragraphs look like in it:

First paragraph.

Second paragraph.

Third paragraph.

This on the other hand is not:

First paragraph.

     Second paragraph.

     Third paragraph.

That is one paragraph and two lines of a code block. Now, if you remove the empty lines between those, then it isn’t even that. Now it is one paragraph with spurious tabs inserted between some of the sentences.

In short, with Markdown you format things after the fact, not as a matter of input. If you want paragraph indenting then that is a matter for CSS, or your word processing stylesheet. In the case of Scrivener converting MultiMarkdown to rich text, it is your compile settings which take your raw paragraphs and formats them with indents (like how the Manuscript formats work).

That all said, I would very rarely recommend using that approach. You will almost always get a better result using the dedicated Markdown-based settings at the bottom of the Compile for dropdown. Those systems do a much better job of conversion, and actually recognise all of the CommonMark specification. Scrivener’s conversion is quite limited, and of equally limited use. I’d say the main reason to use it is if you really don’t like Pandoc’s ePub workflow and want to use Scrivener’s instead, maybe out of familiarity—but even so since it only supports a limited subset of Markdown syntax, it is going to only be viable for relatively simple works (in terms of formatting demands.

And either way, you will of course need valid Markdown input.