Tabbed indents?

So when I copy paste a document into Scrivener on Mac, it shows up exactly as I want it to. There is no auto indent and the tab-key indents are displayed the exact same way they are as on Pages or Google Docs.

However, when I do the same in the Windows version, it first applies an annoying auto indent. I ended up turning that off, but the tab-key indents ended up being ridiculously long, at 1 full inch each. Any way to fix this problem for good?

I haven’t tried to do the specific thing you’re trying, but have you looked at tab stops in the ruler (Ctrl+Shift+R) before pasting in text? If there are tab stops set there, you can change them. Section 15.4.1 of the manual explains how to set and change these tab stops.

This will affect the current document only. To change the default for new documents, go to Tools > Options > Editor. In the box labeled Default Main Text Attributes, there’s a ruler that you can use to set tab stops. Right-click in the ruler and select the kind of tab stop to add. You can drag them left and right to get them where you want them, and drag them all the way to the left to delete them. Once you’ve done that, existing documents can be conformed to the new settings by using Documents > Convert > Formatting to Default Text Style in each document.

I too have not tried this as I do not use the source so not sure if this is relevant to your problem. However whenever I do something similar from outside sources I copy the original, right click in the Scrivener pane and choose Paste and Match Style to match to my default Scriv page style

Tools->Options->Editor (Scrivener->Preferences->Editor on mac) is where you want to adjust tab stops and paragraph indents for all new documents. Once you have that set up the way you like, select documents in your binder already and use Documents->Convert->Formatting to Default Text Style to make them conform to your new defaults.

One thing I feel compelled to point out: using TAB characters to indent paragraphs may very well cause indents to be erratic for some compile formats. Using the auto-indent will save you (and any editors/typesetters) headaches down the road.