Table of Content (Layout)

Hi guys,

i’m from Germany - excuse my english. :wink:

I’m using Scrivener for a few days now to write my thesis. Everything works fine except the table of content. I already read the help and searched the forum for help. No success. :frowning:

So my question - i already copied all parts an used “copy to TOC”. I get a list with all titles and links and page numbers. But it looks like crap. Is there a way to add numbering (automatic), styles and so on? I also found no tutorial or s.th. else on youtube to solve my problem. any hints?

Thanks! (Gerne auch Antworten in deutsch oder Kontakt zu deutschen Nutzern!)

Nils

PS. Feel free to correct my grammar.

Hi Nils,

You can format the table of contents however you want - it’s just regular text but inserted as Scrivener links so that the titles and page numbers can be updated during the Compile process to reflect the documents they link to.

As for automatic numbering, you can add this to the titles via the “Title Settings” in the Compile > Formatting pane, and the titles in the table of contents will automatically update to reflect this. To see what I mean, try the following:

  1. Create a blank project (just for testing) and add a few documents to the Draft folder, in whatever structure you want.

  2. Create a contents page document, select the other documents in the Draft folder, and use Edit > Copy Special > Copy Documents as ToC and paste the results into the contents page document.

  3. In the Inspector, click “Compile As Is” for the contents page.

  4. Go to File > Compile…

  5. Go to the “Formatting” pane.

  6. Select the text document row (the third row in the list) and click on “Title Settings…”).

  7. Tick the “Title” tick-box for that row.

  8. In the “Prefix” text field, type “Chapter <$n>” (the <$n> is an auto-number tag - you could also add it using Edit > Insert > Auto-Number) and hit return.

  9. Click “OK”.

  10. Click “Compile” and chose “Open PDF in Preview” from the “PDF” button in the print panel.

If you look at the contents page in the resulting PDF, you will see that its titles are now auto-numbered to match the document titles.

That should give you an idea of what is possible. You can format the table of contents however you want just as you can regular text, and it will update the titles based on your Compile settings.

You’re right, though, we definitely need a video tutorial on this - it’s on the list!

Hope that helps.

All the best,
Keith

Thanks for the quick help.
With your help i was able to create a ToC with auto-numbering. Font, size and so on is even easy to change.

But… every page number is moved to the next line. Also i want to use different kind of numbers, e.g. 1,2,3,4 for the content and I, II, III, IV for ToC… !
An other point is the numbering. I use as prefix "<$hn>. ", but scrivener shows in the ToC “1 - Title”.

I added 2 links, Scrivener and Word, to show what i mean
dl.dropbox.com/u/7588646/example_word.pdf (This is how i like it)
dl.dropbox.com/u/7588646/example-scrivener.pdf (This shows scrivener :frowning: )

Btw. your App is great… :smiley:

Thanks
Nils

Hi,

For a start those question marks mean that the document linked to could not be found - maybe it has on content or isn’t included?

As for where the page numbers appear, you just need to adjust the ruler in the contents page to tweak the tab placement. Entering page layout view is a good idea for this.

All the different auto-number types can be found in the Edit > Insert > Auto-Number menu, but the tag for uppercase Roman numerals is <$R>.

Hope that helps.

All the best,
Keith

Alright, managed it to change the position of the pagenumbers. It’s a bit annoying that you have to edit each line separately, otherwise I lost the structure of the index. (All lines are left justified even though there are sub-chapter …).
I also changed the pagenumbers to $, but now i need the numbers also shown on the pages, not only in the ToC. Is there a way?

Next thing is the “-” between the number of the section and the title. I would like to replace it by a “.”

And at last, is there a way to insert “…” between title and page instead of the underlining?

Thank a lot!

Nils

You can hold down the command key while clicking and dragging to select multiple non-contiguous ranges of text, which allows you to apply formatting to multiple panes at once.

Instead of adding the <$R> to the ToC you should add it to the title prefix in the Formatting “Title Settings” in Compile. The links in the ToC will automatically be updated to show those.

Take a look in the “Processing Options” Compile pane.

Choose the underline style from the Format > Font > Underline menu for the tab area.

I think the main problem here is that we need a good tutorial video showing how to set things up, as it’s fairly straightforward once you understand how it’s all put together but I can see why it’s confusing without some better instructions available. For instance, here’s the ToC for our internal file format specs document, which was created using the Copy as Linked ToC feature and created by generating a PDF from Scrivener:

It took me about ten or fifteen minutes of tweaking it to get it looking like that, but of course I have the advantage of knowing all the ins and outs. :slight_smile:

It is on our list to provide a solid video tutorial explaining all of this (and high up on our list too).

All the best,
Keith

Thanks buddy,

this is really the best support I ever had. Although I have not even bought the program. But I’ll do !!!, well everything works fine now!

Big thanks - see us next challenge!

Glad you got it working, and thanks for the kind words! As I say, we really do need to cover how to do this better and hope to do so soon.
Thanks again,
Keith

Hey,

now I have another problem. I to use RTF format because of the footnotes. But the page numbers disappear and it will only “?” displayed. When I compile a PDF page numbers are displayed …

Whats wrong? (Include RTF boomarks is on)

Greetings

Hi NilsZ, I’m assuming you’ve opened it in Word? For some reason Word doesn’t update the page number fields until it’s ran a print preview. So, just hit cmd-P or go to File > Print in Word, and this should update the fields and replace the question marks with the page numbers (you don’t need to actually print, just calling up the print panel should be enough to force Word to update the numbers). Note that this is mentioned on p.253 of the manual.

Hope that helps.

All the best,
Keith

Thanks… works now!

Other Problem. After adding an image i always have a lot of free space above the image and i’m not able to remove it… http://cl.ly/081x2S1Y3e3c150I0X0m

Any idea?

That’s just line spacing. For some odd reason, in Apple’s standard OS X text engine, if you have 1.5 line spacing then the 1.5 multiple is assigned to the height of the image on the line rather than of the font size. To fix it, just select the image and change the line spacing to 1.0.

All the best,
Keith

Thanks!

IS there also a way to insert a list of figures whitout typing everything manual?

Greetz

Finished my work…

big big big big Thanks to you! Great App, had fun working with it! Keep it up!

Greetz!

i have a similar problem so solve. my toc shows me the numbering just continiusly (1,2,3,4,5,…), even for sub-chapters. the same happens when compiling a pdf with the titles, although i structured right in the draft.

but i need a numeration in the toc and at the titles as showed in a reply before:
1.
2.
2.1
2.2
2.2.1
3.
4.
4.1

how can i do this? i can’t find anything in the manual. i’m using actually the trail version 2.0.2. on lion, is that associated with this?
thanks for your help in advance!

Well, as an aside you should definitely upgrade your copy to 2.1 if you are using Lion. Let alone the hundreds of bug fixes that have been applied since 2.0.2, version 2.1 is the only one that is designed to be fully compatible with Lion. Just use the main Scrivener application menu to “Check for Updates”.

<$hn> is the counter token that produces sectional numbering like you describe.

To pick up on something Nils already asked about, but hasn’t been answered yet (I think): is it possible to have two page number styles? What I need is quite simple:
the first 20 pages need to be numbered as I, II, …, XX
afterwards, the count restarts and continues as 1, 2, 3, …, 350 (until the end)

Or do I need to work with page breaks or something in Word for that?

You need Word (or another program similar) for that. Scrivener can set up an alternate header/footer for X number of pages, or whatever is in the Front Matter folder that you select, but it only has one form of page numbering.

Thanks.