Table of Contents Snafu

I’m at that last step of my next novel – creating the Table of Contents but can’t get one of the chapters to work properly. When I use the Copy Document as TOC it gives me the error as shown in the first attachment, and then also shows improperly in the PDF. (see next to last chapter where the error is occurring.)

I’ve even tried creating a new folder with new files underneath (with the text clipped and pasted into the files.) Got the same error.

Can you help me correct this?

I’m using Scrivener for Mac 2.3.1 (20025)



Just type in an extra tab between “Savior” and the “<$p>”. Or, select all, and get rid of the that is causing the problems in the ruler. It’s not an error, it’s just that Scrivener has to make a best guess about where to put the tabs. When pasting a ToC, Scrivener adds a left tab at 0.5" and a right tab at the current right margin according to your page settings. The left tab is in case there is a title prefix added during Compile with a tab after it. In your case, “Savior” is smaller than 0.5", so the <$p> gets placed at the 0.5" tab rather than getting pushed over to the right tab as the others do.

Thus, you just need to rearrange the ruler tabs. This will generally be necessary when pasting as a ToC seeing as Scrivener doesn’t know the content or the intended compiled format.

Hope that helps.

All the best,

that worked! Thanks