Table on Contents formatting

I haven’t updated my TOC for a long time. The previous version of this TOC has enough leading dashes to place each page number link aligned on the right of the page. But when I attempt to do it now, they are not shoved to the right like that. How did I do that before?

From the sound of it, you probably used the Edit/Copy Special/Copy Documents as ToC menu command. Chapter 23 in the user manual discusses the details on how to use it, but it’s very easy: just select the items that should appear in the ToC, in the Binder and then use that menu. That will give you text you can paste into your contents document. Note that it uses tab stops, so if your editor is narrower than the rightmost tab then it would wrap the page number around to a second line—but that’s just a visual thing. So long as the tab stop falls within the page and margin settings for compile, it should look good in the end (or you can just widen your editor window).

Got it. Thanks. Didn’t see that it was a tabs setting.

Actually, I see that when I first Paste the Copy Special, all the topics are indented properly, based on relative position in Binder. But when I apply tabs to the entire section (0 inches Left Aligned, 6.5 inches Right Aligned), I get the page references all right aligned, but all the topics are now flush left. But my old TOC has all the page references right aligned along with the topics correctly indented, honoring the Binder layout.

Each indented level has its own ruler settings to achieve the indent. So if you globally apply one single ruler setting to all of the lines, then they will no longer be indented neatly. Basically, if you want to modify the look of the table, you need to make you changes to individual indent levels independently. In other words, fix one level 1 row, and then use the Format/Text/Copy Ruler and Paste Ruler functions to copy those settings to all of the other level 1 lines—then move on to the level 2 items.

I see. Well, I just don’t remember going through all that when I last generated a TOC, but that was some time ago. Anyway, thanks, your method works fine.

Now I see how I used to do this in a way that saves having to reformat my TOC every time I update it. After you do your Copy Special TOC, select the TOC document in Binder (as opposed to moving to it in Scrivenings Mode). Now select all the text in that single document (put your cursor in that document and hit Cmd-A). Now paste (Cmd-V).

If you do it this way, all your prior formatting will be honored, level by level. However, if you simply overwrite the selected TOC text when in Scrivenings Mode, you will lose your original TOC formatting.