Tables and Images- what is the best practice?

I have been playing with the compiler, which works amazingly well, but I can see already that I will be having some major issues with tables and images, depending upon the format. So, I have a few questions.

Situation: Book is essentially done. Want to move it to epub, mobi, pdf for printing, etc.

Problem: Book contains tables and images.

The table editor seems really difficult. Great for dropping in some data, but limited control. Words wrap weirdly, etc. I am assuming if they are not great in Scrivener, things will only get worse when exporting.

Proposed solution: I can remake the tables at any size in Illustrator, and insert them as an image, rather than as a table. I am guessing that will be the best approach. (true or false?)

Assuming placing images is better…

What is the best way to format an image for epub, mobi, etc? Should there be page breaks before and after the image? Drag and drop, or Insert? What is the difference between Insert Image From File and Image Linked To File?

Is there a way to open these epub and mobi files and edit them? (I can open the pdf in InDesign, so no problem there)

What is the best format? (jpeg,png, etc?)

What size for which format?

What is too small in a mobile format?

Thanks for any insight you can offer,

Tables are going to be tough in e-books. Support for them is spotty in the readers themselves, and large tables will never display the way you intend on small devices. I’ve seen a few professionally made e-books with real HTML tables, but usually they use an image of the table so that good formatting can be done and the table doesn’t break across screens or anything.

You may not have to remake them though. You should be able to export them via compile to a format your software can read in and just touch them up then save them as graphics. InDesign and RTF might be the best combination here.

That’s a subjective choice, I’d say. For small images it’s probably not worth the hassle, but if you fear the image is large enough to make for ugly one-liner texts above or below it on some displays, then separating them out is okay. If you do that though, you’ll need to make your own ToC instead of relying upon Scrivener’s automatic generator. It uses section breaks to build the list, and you probably don’t want stuff broken up that way in the ToC. You’ll find instructions for doing this in Ch. 23 of the user manual.

An image imported into a text document is just that. It doesn’t matter how you get it there.

Images are fully discussed in §15.4.7 (pg. 203), and specifically linked images on pg. 205. Just think of how InDesign works for the latter. Resource isn’t embedded in the page as a long string of bytes, it’s just a pointer to where those bytes are on your disk. Neither method is of any practical difference during compile; the only reason to choose one over the other is workflow.

Either is fine; the main thing to worry about is DPI. Most e-book readers assume 72, so if you drop a 300 DPI image into them it’ll make a mess of things. 800x600 is a good max unless you are targeting a high-res display like the iPad.

I need clarification on what you mean by that. I can’t think of anything that would be too small. You can use a graphic to draw little dividers between scenes in a novel, for instance. It’s too big that is the main problem. You don’t want to deliver a 50mb e-book if you can help it. Delivering that over a cellular link would be painful, and a lot of devices have very limited storage space.

Well, I am a happy camper. I figured out some things I was doing wrong, and was able to get a table into Kindle.

(Automatic indenting was screwing up my tables)

Next question: Is there a way to copy a table, so the can all look uniform?

…ugh. never mind that question. I have a more pressing issue.

When I compiled for Kindle, the tables just disappeared. The data printed, roughly formatted, and the borders were gone.

I thought it might have been some background color I added to the cells, so I removed the color. No luck.

I know tables and compile work for Kindle. I did a test with one page, and a table was the only item on the page. Is this a bug of some sort?

What am I doing wrong?

…maybe just placing them as images is the best approach after all. I need to do images anyway for a couple of graphs.

The Kindle can be a bit temperamental with tables, I believe (especially longer ones), but feel free to send a copy of the project (zipped up) to us at AT literatureandlatte DOT come and we’ll be happy to have a look at it.

What I’m thinking of doing is adding an option for e-book Compile, “Convert tables into images”. I think I have a way of doing this that should work well, but I need to investigate it, as it’s not simple. I think it would be useful for a lot of users, though, seeing as most books seem to include tables as images.

All the best,

Thanks for the offer, but I just deleted a bunch of the tables about an hour ago. I remade them in Keynote, and they are so much more pleasing to the eye, that I don’t think I will be going back to tables anytime soon.

I am finding the images a bit quirky. In scrivener, they have a tendency to place on top of text, or over another image, and it is hard to grab it with the mouse to access the resize dialog.

When I did a compile, the spacing was weird. Not surprisingly, as I inserted a bunch of carriage returns to get the image off the text in some cases.

The first image went in well, as I recall, but the subsequent ones were less forgiving.

I am going to try the <$img:IMAGE_IDENTIFICATION;w=WIDTH;h=HEIGHT> image tag instead, and see if that gives me some better control.

I resized the images to 800x600 as per AmberV’s suggestion. They were originally larger in Keynote. While they fit in Scrivener width-wise, I needed to resize them because the height was a problem. It seems like they paste and the text doesn’t move to accommodate the height. It just overlaps everything above, and I need to click about a 1/2 inch below the image to get the dialog to appear.

Despite these hiccups, the software is pretty amazing. I have been using it to write for a long time, but not for compiling and exporting. I want to get it perfect for Kindle (I still have a little writing to do) before I futz with the other formats. It’s pretty cool though, I can read my book on my phone. It’s gone very well.

…wow, the image tag worked like a charm. I feel so empowered! lol
This is going to be great.

Thanks for all your help.

Do you perhaps have an exact line-height set in the paragraph you paste the image on? Ordinarily the image will push all of the text aside when you paste it, but if the line-height is fixed to a certain height it’ll behave oddly unless the image is designed to work at that precise height (like inline icons for instance). To check this, place the cursor in the paragraph where you intend to paste, and use the line-height tool in the Format Bar. Select “Other…” and check the settings there. A good setting for images is a 1.0 multiplier with maybe a before/after paragraph spacing to set it apart from the text a bit.

Yep, I had the line height set to exactly. That must have been the problem. Thank you.

I have another question in regard to images. Nothing shows up in the Cover Image pop-up under Compile.

I do not expect the images that are placed via a command line to appear.

I inserted a jpg for the cover into a document named Cover, but nothing I do can get it to appear in the pop-up.

I have created documents in both the Research folder and outside of the Draft folder, and have tried changing the images, too. Nothing seems to work.

Problem Solved, I think.

It dawned on me that perhaps the problem was related to the fact that the file had been updated from one version of Scrivener to another. I created a new project, created a new page, and the images showed up under Cover with no problem.

I have yet to move all the pages over, but I suspect there will be no problems.

You need to import the cover image into the project as an image file - that is, drag the image into the binder directory (not into the Draft folder, but anywhere else), or use File > Import > Files… and import the image file that way. An image placed inside a text document is just part of the text, so cannot be used as a cover image.

All the best,

I still have trouble getting this to work. In most cases, Import Files is greyed out.

However, if I right-click within the Research Folder, Add Existing File, then it chooses the file and automatically names it cover? (which is the name of the file). And it seems to display a cover icon, too.

Any guesses on why it is grey out from the menu bar? Am I missing something obvious?

It matters where your selection is in the binder, when using import. Your selection is used to place the imported documents where you choose. So if you select a place that is not eligible to import items of a certain type (or at all, in the case of the Trash), then certain types of files will not import. Fortunately this is easy: the Draft only takes supported word processor formats and plain-text documents. Everywhere else in the binder will take any type of file (unless you have the Import/Export preferences set to exclude unsupported file types—that is files that cannot be viewed in the editor).