Tabs and indents (in lists)

I occasionally get back to Scrivener to use it for writing, but the thing that completely freaks me out is the bullet and indenting. I can never get this right.

What I want is simple: the same tab stops all over my document, including the “no style”. Markign a paragraph as bullet should neatly indent it and align the paragraph under the bullet neatly (everything indented). When I press enter at the end of the parapgraph, a new bullet should appear. etc. When I indent a bullet, it should neatly indent under the text of the previous bullet (not 2 cm more which makes everything look annoyingly awful).

Then when I go to another paragraph and select bullet style, it should just behave like the first one. Not one big mess yet gain.

Not should one have to create special bullet styles and jumpo through all sorts of hoops to get something that looks decent, just to wait for everythign to mess up again.

Scrivener tend to mess up indents everywhere. Is it so difficult to creatae neatly aligned bullets, same everywhere in the document?

I read tons of posts on this. Nothing helpend me. Spend countless hours trying to get “something” working along the lines.

Then I don’t use Scriverner for a while, get back and… ho my, tab hell again.

This is a real annoyance. Not sure if I am the only one, but imo this really needs improvement.
Something that should be obvious and simple seems nearly impossible in Scrivener.

At least write some decent support document on it: simple and consistent bullets…

Don’t tab.
I use the Ruler which I’ve set to snap at set intervals. You may wish to use the menu options to get similar results.
Always move the First Line indent (the top one) to the required gap and leave the Left Indent at zero for your first level indent. (So, the approach is to have the Left Indent at a lesser value that the First Line Indent.)
Next, I setup my required bullet and numbering gap. Once I’ve setup the first indent, I save it as a Style, calling it Bullet_L1. Then I set the next level and save it to another Style, which I call Bullet_L2.
Next, I type out my list, unnumbered or bulleted. Then I select bullets or numbers by clicking on the list icon and choosing what I require.
Once a list is numbered or bulleted, I highlight it and apply the Style I’ve setup and it neatly positions my numbered or bulleted list.
I’ve also setup such for lists in Table cells, which works using the same approach, though they require separate Styles for each level of indentation.
I don’t know about Mac, but on Windows bullets in the editor and their output position are visibly different to the output (probably because Scrivener isn’t WYSIWYG). However using the Ruler, I get the right look and gap in a WYSIWYG app like Word, it just looks odd (compact) in Scrivener’s Editor.

Hi Kevitec,

Thanks for your reply. I used similar approach, but find it very inconvenient to use styles for indent levels. When I write, I tend to roughly draft texts with bullets, often rearranging until I completely write out text. I do not write novels, but draft business plans at all, which tend to have lots of bullets, tables, and ‘outline like’ think processes. Having to mess with indents and style changes distracts from writing so much. It annoys me, distracts from work and causes the quality to become less than it should. It is like paining without proper pencils.

The defaults Scriveners uses are awful, with first indents, and everythign out of line. It feels like a how with a picture wall where everything is crooked. Looking like that at my text makes me hate it… lol

I do not understand why this is so badly implemented.

Anyway, I really appreciate your explanation. I’ll might give it one more chance before redirecting this (otherwise quite handy) tool to /dev/null.

In the meantime I thing this is something Scrivener should really improve on. At least provide decent documentation on how to quickly set up (or change) all this.

Thanks again!

Hi Hans

In the Editor, I always have my Ruler on by default.

When it comes to lists, outside of writing, I do use the approach as used in, for example, Word, where the First Line Indent is kept at zero and the Left Indent at 0.75 cm, as well as a left tab (right-click the Ruler at 0.75cm and select from little context menu that pops up).

In Scrivener Settings > Editing > Options (I hope I have that right for Mac–I’m guessing here), you will find Ruler Units and Ruler Snap Every choices. I set my Ruler to snap every 0.25 cm, so if something in my list jumps out of alignment, I drag it to an exact value on the Ruler. And I don’t need to work through menus all the time.

I’ve seen some people use Styles for first paragraph of a chapter and scene to be without indentation. I simply drag the First Line Indent to zero and the next paragraph to 0.75 cm and it snaps without hassle.

Hi Kevitec,

I hev been doing mostly all you refer to, but I still consider things cumbersome. That is because tabs may be different in each paragraph. That means you can hardly “set u up and forget”: things tend to mess up time and again. My experience is that this becomes even worse if once you start dragging tabs in the ruler, because as soon as you go elsewhere in your document, the ruler changes again. There is no option to set and fixate a “project based ruler” (as far as I know) that works well, even when using “no style” everywhere.

I did use to set styles per bullet, but once the writing becomes more and more complex, you have to select text, select style etc. Focus is not on writing any more, but on “keeping decent oversight of what you are writing”. That is: the more you write, the more you loose oversight. The whole point of a tool like Scrivener is to be able to focus on content/text without too much distraction.

Constantly havign to fiddle with settings (everywhere) deviates from the purpose.

I can understand there are some implementation issues, because Scrivener works with preconfigured text boxes on mac, but then again: make things easy by design, not complex.

As advocated, I do not prefer using styles per bullet indent level. In “No Styles” settings things should work properly as well (they don’t). That is my main objective.

Things like this should be simple and by default.

I try to love Scrivener, as I love being able to put notes, bookmarks, etc alongside what I am writing. But I hate the fact that some simple things are so darn hard to accomplish. Until now I have always had to use Scrivener for draft versions, and when (almost) final copy and paste everything into a word processor to get styles, tabs and settings look the way I want to. But as soon as I’ve done that, there is no way back…

PS: though it may sound so, this is not meant to be interpreted as a rant. Rather a stimulation to make simple things easy and simple. Even in the most basic editor with fixed font I can use tables that align well…

1 Like

There was a response here some time ago that lists and tables are packaged elements that come with the development framework. I’m not sure it applies on the Mac side, but that was my understanding on the Windows end, which is developed on the Qt Framework.
It would take more than a full-time developer working on those components to extend the experience to the way it’s implemented by the companies with deep pockets and is not the core focus of Scrivener. Whether it has a widely interested user-base in Scrivener is unknown.


Uh, why?

Consistency is good typographic practice.

FWIW, the “default” ruler is defined in the same places that other default formatting is.
The Project → Project Settings → Formatting pane sets the default for the current project, or Scrivener → Scrivener Preferences → Editing → Formatting sets the default Scrivener-wide.


Thinking outside the box here, but I also have a similar (non-fiction) workflow… May I suggest using your binder structure for your “bulleted/indented lists” - which is how I approach things.

The beauty of this, is that you can easily add a new item (doc), drag/drop it anywhere, and not screw up your numbering or indents.

Using your outliner in a split window/QRP will show your “outline” structure and can be set to also show numbering as a reference while you work in the editor.

You don’t have to name the docs, the default will use the first few words/sentence so in your binder and outliner you will effectively see your indented “lists” (the font will be in italics and grey if you don’t add a name to your docs)

It’s quite easy at compile to have everything print in an indented and auto numbered “list” This was my selling point as I frequently have to add/delete/move items(docs) and also have to use varied numbering (I,II,III; i,ii,iii;123, ABC, abc at different levels)- which had been quite tedious (over 6000 in the 1-2-3 list) but now as long as my binder structure is correct, and once my compile settings are set, I never have to renumber or reformat my “lists” I can add/delete/move items/docs anywhere and not screw up any numbering even when my binder is many levels “deep”.

I don’t have time to go into the compile settings, but will be happy to elaborate if you are interested. Setting the compile up takes a few minutes, but once it’s done, it can be reused over and over.

1 Like

FWIW: what I meant with my sentence is: “that’s the way scrivener seems to work”.

I will look into it once more, but honestly, I have spend days and days trying to set things up correctly and never got any further than “barely acceptable with styles”.

Maybe the way I write document is “not the right way” LOL

Thanks, you may have found a very creative way to solve the puzzle LOL.

I doubt this is workable with large documents, but I will look into it. Thumbs up for creativity.


I think I read that as well. Hence my remark on “implementation issues”. It is likely that the underlying cause has to do with it, but in my opinion (being a software developer myself) that is not much of an excuse. If it is, other ways should be found to automate such a thing. Maybe there is, but I have not found it (believe me: I dug quite deep in the settings hell of Scrivener).

Just suppose you want to write plan text release notes, like this:

* release 1.0
  - improved bullet style items
  - problem:
    - the first problem to solve was to ...
      neatly indented text on second line!
    - the second...
      - third level
        - fourth level

* release 0.9
  - proud to launch the alpha version 

Writing such kinds of lists in Scrivener document’s is very unpleasant. Just try it with a fresh document. The ‘-’ will not be aligned, just ends up somewhere. You have to start using styles and all kinds of hoops to jump through.

I tried markdown, fixed fonts, tab settings, indenting, default styles, special style, whatever. You have to be meticulously write everything… just to find out it has been messed up anyways.

I know, just a simple sample as above can be fixed incidentally, but when you write tons of (tech) documents, project planning, and stuff like that: it is no fun.

I will give up my attempt now, it costing me too much of my precious time already: I need to strat writing :wink:

Thanks everybody for your kind words and suggestions!

I see the problem (not the solution).
The expected behaviour is the list should keep using the dash as a bullet, but when you press Return after the last item the list reverts to the Scrivener default for documents. And any Paste and Match Style does the same.