Target Notifications Suddenly not showing up anymore

Until the past few days, a little box notifying me when I reached my daily target showed up on the screen on my mac.

Last few days it does not. I have not changed any setting I’m aware of and in face when I got to options on the project targets, it does still have a check beside show target notifications.

Can anyone tell me how to make it start showing those again please.


Ok, well. . . today the notification did show up.

I realized that I had changed one thing, I’d checked the box that said allow writing on the day of deadline. I unchecked that yesterday and today it showed up the target met notification when I met my goal.

I don’t know if that change was what made it not show up before or if it was just a temporary glitch with my computer. But thought I’d mention that its working again and if anyone else has this issue, maybe give that a try.


I’m having this same problem, but it doesn’t seem to matter whether or not allow writing on day of deadline is checked. In fact, doesn’t matter if there even is a deadline. Target notifications is checked and I’ve confirmed Growl is configured correctly, but for whatever reason, Scrivener will not show target notifications. It’s across the board in all projects, too.

Any ideas what the problem might be? Still having this problem and still awaiting a response.

Do any other types of notification work? For example can you try setting a document goal (the target icon in the footer bar) of ten words, with the notification checkbox on, and see if it triggers there? I’d have the Console log output open while you’re trying this as well.

No notifications are working. Here’s what the Console tells me:

[code]Scrivener(76580) deny appleevent-send com.growl.growlhelperapp

Process: Scrivener [76580]
Path: /Applications/
Load Address: 0x1000
Identifier: com.literatureandlatte.scrivener2
Version: 2.5 (2.5)
Code Type: i386 (Native)
Parent Process: launchd [236]

Date/Time: 2014-01-23 06:22:16.212 +0900
OS Version: Mac OS X 10.9.1 (13B42)
Report Version: 8

Thread 0:
0 libsystem_kernel.dylib 0x90e35fb6 semaphore_wait_trap + 10
1 libdispatch.dylib 0x910def43 dispatch_semaphore_wait + 37
2 AE 0x9c2e4fa0 _AppleEventsLookupApplicationPort + 239
3 AE 0x9c2e951c findPortByPSN + 373
4 AE 0x9c2e4b70 EventAddress::copyAddressPort() const + 272
5 AE 0x9c2e36a7 AESendMessage + 3163
6 Growl 0xc00033c6 +[GrowlApplicationBridge _launchGrowlIfInstalledWithRegistrationDictionary:] + 1408
7 Growl 0xc00018ab +[GrowlApplicationBridge setGrowlDelegate:] + 971
8 Scrivener 0x002b1977
9 Scrivener 0x0020f85a
10 Foundation 0x96b48692 __57-[NSNotificationCenter addObserver:selector:name:object:]_block_invoke + 49
12 CoreFoundation 0x900e93fb _CFXNotificationPost + 3435
13 Foundation 0x96b36ebf -[NSNotificationCenter postNotificationName:object:userInfo:] + 92
14 ScrAppKit 0x00479669 -[KBTextStorage replaceCharactersInRange:withString:] + 552
15 AppKit 0x9b930286 -[NSTextView(NSPrivate) _userReplaceRange:withString:] + 207
16 AppKit 0x9b92ffa4 _NSDoUserReplaceForCharRange + 394
17 AppKit 0x9b92fe0f _NSDoUserDeleteForCharRange + 78
18 AppKit 0x9b92f467 -[NSTextView(NSKeyBindingCommands) deleteBackward:] + 323
19 libobjc.A.dylib 0x90b052af -[NSObject performSelector:withObject:] + 70
20 AppKit 0x9b8b0887 -[NSResponder doCommandBySelector:] + 91
21 AppKit 0x9b8ded93 -[NSTextView doCommandBySelector:] + 152
22 AppKit 0x9b8decea -[NSTextInputContext doCommandBySelector:] + 119
23 AppKit 0x9b8dec68 -[NSTextInputContext _handleCommand:] + 84
24 AppKit 0x9b8afef2 -[NSKeyBindingManager(NSKeyBindingManager_MultiClients) interpretEventAsCommand:forClient:] + 1186
25 AppKit 0x9b8cf306 -[NSTextInputContext handleEvent:] + 1467
26 AppKit 0x9b8ae6a3 -[NSView interpretKeyEvents:] + 205
27 AppKit 0x9b8cec63 -[NSTextView keyDown:] + 680
28 AppKit 0x9b878fd6 -[NSWindow sendEvent:] + 4154
29 AppKit 0x9b816cad -[NSApplication sendEvent:] + 4034
30 Scrivener 0x00050dd9
31 AppKit 0x9b65b3bc -[NSApplication run] + 823
32 AppKit 0x9b6441f8 NSApplicationMain + 1165
33 Scrivener 0x000353a9
34 Scrivener 0x00002c55

Thread 1:
0 libsystem_kernel.dylib 0x90e3b046 __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x9182ecce start_wqthread + 30

Thread 2:
0 libsystem_kernel.dylib 0x90e3b992 kevent64 + 10
1 libdispatch.dylib 0x910dc556 _dispatch_mgr_init + 0

Thread 3:
0 libsystem_kernel.dylib 0x90e3b046 __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x9182ecce start_wqthread + 30

Thread 4:
0 libsystem_kernel.dylib 0x90e3b046 __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x9182ecce start_wqthread + 30

Thread 5:
0 libsystem_kernel.dylib 0x90e3b046 __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x9182ecce start_wqthread + 30

Thread 6:
0 libsystem_kernel.dylib 0x90e3b046 __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x9182ecce start_wqthread + 30

Thread 7:
0 libsystem_kernel.dylib 0x90e35f7a mach_msg_trap + 10
1 CoreFoundation 0x9014ff69 __CFRunLoopServiceMachPort + 169
2 CoreFoundation 0x9014f541 __CFRunLoopRun + 1393
3 CoreFoundation 0x9014ed5a CFRunLoopRunSpecific + 394
4 CoreFoundation 0x9014ebbb CFRunLoopRunInMode + 123
5 AppKit 0x9b812f18 _NSEventThread + 283
6 libsystem_pthread.dylib 0x918295fb _pthread_body + 144
7 libsystem_pthread.dylib 0x91829485 _pthread_struct_init + 0
8 libsystem_pthread.dylib 0x9182ecf2 thread_start + 34

Thread 8:
0 libsystem_kernel.dylib 0x90e3a7ca __psynch_cvwait + 10
1 libsystem_pthread.dylib 0x9182dbd9 pthread_cond_wait$UNIX2003 + 71
2 CoreVideo 0x910f4540 CVDisplayLink::runIOThread() + 936
3 CoreVideo 0x910f4180 startIOThread(void*) + 159
4 libsystem_pthread.dylib 0x918295fb _pthread_body + 144
5 libsystem_pthread.dylib 0x91829485 _pthread_struct_init + 0
6 libsystem_pthread.dylib 0x9182ecf2 thread_start + 34

Binary Images:
0x1000 - 0x342ff3 com.literatureandlatte.scrivener2 (2.5 - 2.5) <3a73d332-e73c-3548-9c88-e6a4ba87b153> /Applications/
0x3a5000 - 0x4fffff com.literatureandlatte.ScrAppKit (1.0) <6af6feee-9ea0-3a65-a826-2de18b84b23d> /Applications/
0x900d9000 - 0x902dbff7 (6.9 - 855.11) <50f70e07-043a-3a2f-87ef-a36ba6c5c9d9> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
0x90aeb000 - 0x90c934af libobjc.A.dylib (551.1) <31cbe178-e972-30d1-adc6-4b8345cae326> /usr/lib/libobjc.A.dylib
0x90e23000 - 0x90e40ff4 libsystem_kernel.dylib (2422.1.72) /usr/lib/system/libsystem_kernel.dylib
0x910d9000 - 0x910f1ffd libdispatch.dylib (339.1.9) <6249bae5-044f-3a7a-9ccc-03ff7e6b405b> /usr/lib/system/libdispatch.dylib
0x910f2000 - 0x91119fff (1.8 - 117.2) /System/Library/Frameworks/CoreVideo.framework/Versions/A/CoreVideo
0x91828000 - 0x9182fffb libsystem_pthread.dylib (53.1.4) <8b1b7b84-1b5d-32a8-ac0d-1e689e5c8a4c> /usr/lib/system/libsystem_pthread.dylib
0x96b34000 - 0x96e5fff6 (6.9 - 1056) /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
0x9b642000 - 0x9c25dff3 (6.9 - 1265) /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit
0x9c2d5000 - 0x9c333ffd (665.5 - 665.5) <54f2f247-160c-3a22-a6e3-5d49655a67ab> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/AE.framework/Versions/A/AE
0xc0000000 - 0xc000aff7 com.growl.growlframework (1.2.1 - 1.2.1) <6ddf5398-7b11-2132-4818-5f96b6e061d5> /Applications/

The first time I tried this, I saw Growl was involved, so I turned off Growl notifications for Scrivener but Growl is still appearing in here.

Can you confirm if you’re using the Mac App Store version? Sandboxing may be getting in the way here. You can see there is a denied AppleEvent that triggers this console output, and that is just the sort of thing that will fail in a sandboxed program.

If you are using the MAS version, you can try using the non-sandboxed direct-download version. This will detect your receipt and unlock itself automatically. If you choose to stick with this version, you’ll probably want to migrate your support files out of the sandbox area.

On the Installing the Direct-Sale Version, it says the following:

Does this mean that to avoid this problem I’ve had with target notifications that I need to rename the direct-sale version of Scrivener something else?

In your case, if the direct-sale version avoids the problem entirely, in your shoes I would rather just replace the MAS version entirely and keep the direct-sale version named “Scrivener”. That line is meant for those that intend to run one version primarily, but occasionally want to use the other (like a beta build, or to get around a very specific bug that isn’t generally encountered). If you need to get out of the sandbox permanently, then it would make more sense to permanently switch to the direct-sale version.

Okay, I’ve switched to the direct-sale version, but still not receiving any notifications. Console doesn’t show anything about notifications whatsoever now.

EDIT: Scratch that last comment, I just opened Scrivener again to do some writing and once I deleted the stuff I used to test notifications, I got a notifications saying I fell below the word count threshold. I typed a few words and got notifications that the project target had been hit. So now everything is back to working the way it’s supposed to.

I realize I’m late to this thread, but it didn’t seem to make sense to start a new one. I’ve been a direct download user of Scrivener since the 1.x days (so, long before there was a mac store), and bought 2.x before scrivener was an option in MAS. Is there no way to fix notifications in “composition” mode without buying scrivener all over again in MAS? Thanks!