Text Autoreplace Not Working Properly in Keywords Pane or in Body Text

I think this may be a Scrivener bug as the text auto-replace works perfectly in all other apps.

I have an auto-replace set up in System Preferences so that when I type five minuses together, it’s replaced with a solid line:

However, auto-replace behaves differently depending on whether it’s in the body text or the Keywords box:

If you look at the screenshot, you’ll see that in the body text (higher up) Scrivener is recognising the auto-replace (the auto-replace box has the solid line inside) but when you press enter, it changes what’s in the auto-replace box for an em-rule followed by two dashes (see the text in the line just above the auto-replace). And I have tried removing my em-rule and en-dash from the auto-replace settings, it doesn’t make a difference, Scrivener still alters the auto-replace.

If you put five minuses in the Keywords box, Scrivener again recognises the auto-replace (the solid line appears in the auto-replace box) but when you press enter, it ignores the auto-replace and gives you five minuses. (See bottom of Keywords box where I just hit enter). To get the auto-replace to work in the Keywords box, you have to click on the auto-replace box.

Let me know if you need anything to recreate this.


p.s. I was trying to figure out why I get a -1, -2, -3 numbered list but now I realise Scrivener doesn’t accept repeated keywords, so figured that out, but still have the problem above.