Text Color Remove Color: How to apply to entire project

I am working in Dark Mode. I have imported a screenplay from FInal Draft and the text of every scene is BLACK. I’m not finding a way to select text across ALL the scenes and remove the black color. In Scrivener mode CTRL-A works only WITHIN a scene

How can this be done efficiently. I have over 70 scenes. Are there macros? Keyboard shortcuts?

Have you gone to file- options- appearance editor and change text color. Believe that will change for whole project at once. Not at computer

Under windows there is unfortunately no way to make a text selection across documents’ boundaries.
You’ll have to do all scenes/documents one by one. (Selecting all documents and viewing them as a Scrivening can greatly speed up the process.)

The other option (and that’ll work only if you use a single font across the whole of your project) would be to set the font color properly in the default formatting (either in the options panel or in your project’s settings), and to then convert all of your concerned documents to default formatting as follows :
Documents/Convert/Text to default formatting

The reason I said that it wouldn’t work if you have more than a single font across your project is that you would then end up with all of the text using the one font set in your default formatting. If you don’t mind that, then that would be your quickest option.
Backup your project first just in case some formatting ends up lost. (Which shouldn’t happen, but I might have not thought of everything. Better safe than sorry.)

First thing to do is to check and see if your project’s default formatting is set in its own settings or in the options.
Project/Project settings :
If the box is checked, that is where the default formatting comes from. Otherwise it is in the options.

P.S. You don’t actually want to change the font color for another color in the default formatting, but rather set it to the default color (or no color) :

This will make your text color adaptive ; no matter the theme/background color.

1 Like

Could certainly do that but changing the text color in the options panel for the editor will change text color all at once across all projects globally and can change color multiple times to experment with what you want this way, see the image below.

Unfortunately none of these suggestions worked for my situation. On the right is an imported screenplay from Final Draft, which for some reason is imported with Black text. That is the real issue.

So I want to mass change those scenes to white text on black background, which is my WIndows Dark Mode theme, but not touch the default for the novel. If someone can solve my import black text issue, I would be fine. I can trash the old import and re-import with scene separators if need be. I’m just starting the novelization process anyway.

Does setting the theme have to be done BEFORE any import? I can’t recall what I did first, but willing to re-import.

I am pretty sure I gave you the right instructions…

If you want to test it, select a paragraph that displays as black over black, then :



If it still doesn’t work afterwards (meaning that not only your text was black, but your default color was also set to black – I strongly doubt it (you would have had to intentionally mess it up)), then follow @GoalieDad’s instructions.
[EDIT] From your screenshot I can already tell it is likely not the case. (Unless you have set this specific text to white (not to default color) willingly.)

As for the Convert text to default formatting part, do it with only your problematic documents selected in the binder.
That’ll leave the rest of your project untouched.

Else, it is as I said : select all of those documents in the binder, have them display as a scrivening, and fix them one by one scrolling down that scrivening until you reach the bottom. There is no other way (that I’ve ever heard of).

[EDIT] There is actually another way. The wrong way, but still:
Go back to FinalDraft, make your text white there, re-import.
But note that your text will then be white. It won’t be of the default color.
Meaning : if you ever want to try another theme, you’ll be screwed. You’ll have to deal with this all over again.
Not to mention potential issues at compile. (Nothing that can’t be fixed in this case if you know what to do, though.)

1 Like

I think we’re talking cross purposes. THe suggestions work on any individual basis. I want to convert my 70+ scenes from black to default (white) text IN BULK. None of the suggestions address that issue.

Converting the Final Draft file to white text does not solve the bulk convert issue, either. There is no reason that Scrivener should be importing the text from Final Draft to black text, UNLESS the choice of Dark Mode and then Importing is the root cause.

I’ll change to normal mode and re-import and see if that fixes the root cause.

Well, what can I say ?
That is exactly what my suggestion actually did…
(I’d suggest that you read the thread back from the top.)

Else, just to bring to your attention that, even fixing your scenes/documents one by one in a scrivening, you’d be long done by now.
70 documents to fix wouldn’t take more than say, 15 minutes.

1 Like

Your second step after I have checked whether default formatting is in options, gives me a disabled font panel and I cannot change the text color. ANy clue why that might be?

Ooops, it’s the 'ole “click and hold” issue. OK got that far. So when I do that and hit OK, then all that black text should turn to the default which is white, correct?

Click in the demo text first.
Make sure it is using the font you want your scenes to end up with.
Then set the text to the default color.
OK - Exit

Select your scenes in the binder, and from there follow my instructions related to Convert text to default formatting.

That will have changed the default formatting for all your future documents in all your projects. If that is not something you want, once you are done fixing your imported scenes, in the editor select some text that is formatted to your taste, then, back in the options, click this:

Fix the text to use default color. OK-exit.

That should be it.

1 Like

So that options panel is very explicit in its description. It says “Main text style for NEW documents”. I wouldn’t expect that to have any effect on the imported documents from Final Draft, as they are existing.
In fact, if I add a new document within that screenplay folder, the text is default white.
Did you actually try this with an imported Final Draft document?

. . . . . . . . . . . . . . .

Doesn’t matter. It is no longer a FinalDraft document.

OK, that worked. Thanks for sticking with it. Much appreciated.