Text color will stay selected in Editor (keeps defaulting to blue when I want black)

For some reason, Scrivener will not let me change the main text color in the editor. It currently is set to blue, which I did not set. I would like it to be black. When I select black from the popup window the color swatch changes from blue to black, but then when I start to type, the text changes back to blue. I don’t know if this is a bug or if I am missing something in the settings. I am running Scrivener v. 3.3.1 (15588) on a Macbook Pro with MacOS Ventura v. 13.5.

This is a bit frustrating so any help or advice is appreciated. Thank you!


Firstly, are you sure you want black, or do you want clear (no colour)? The choice on the far left with a red diagonal line through it is the latter. It will of course appear as black in most cases, but that is very different from actually being black.

Secondly, have a look at the user manual PDF, §18.5, Text Colour and Highlights, particularly that introductory bullet list. It kind of sounds like you are describing how it should work.

After that, have a look at the section directly following that, §18.6, on Revision Mode. That would most certainly force all typing to be in blue, if you are currently using Level 2 revisions, as set in the Format ▸ Revision Mode submenu. That is what the feature is meant to do and it will be quite stubborn about it until you turn it off. :slight_smile: Various sub-topics in that section may also be of use at this point, such as how to strip out all revision colour markings.

Thank you so much Amber for such a fast reply. I think it is the Revision Mode that needed changing. Seems to fine now.

I am curious about setting text to no color vs. black. How is this very different? I tried setting text to no color and it types black which is fine, but does the software think of this text as colorless even though it types black? I had not thought of this before until you mentioned this.

Thank you again. Very helpful. :grinning:


Glad it’s all sorted!

The difference between the two won’t be terribly obvious in Scrivener, because it has code to make no-colour and black indistinguishable in the places where it would matter (like Dark Mode, where as you can imagine, literally black text would be awful). Where it can matter more is when you export, as not every editor will handle it as gracefully. In fact Scrivener for Windows didn’t handle it very well for a long time, and we’d commonly get complaints about how taking a project to Windows from a Mac would involve lots of black text showing up in Composition Mode or what have you, where the background was dark.

Thank you Amber. This makes sense and is a good explanation. I really appreciate this info. You saved me some frustration and time.

Yesterday I bought Scrivener 3 for Windows:

  • I created a snapshot for a record, and since I destroyed it, the software continues to write red in all my text files anywhere in Scrivener, which is more than annoying.
  • I tried to change the text color back to black in the Styles bar without any effect.
    What can I do?
    Thank you

It’s very unlikely that deleting a snapshot caused a change in default formatting, especially given your description, which matches an intentional feature in the software. See above for where to look and turn it off.

Adding text only turns red (instead of black) in text files, including those for which no new version has been created. But the addition of text remains black in the synopsis.
I used this program without problems for 1 month, and it seems to me that this problem has appeared since I bought the product, and therefore introduced a license (but I do not think it has a relationship).
It is as if adding a snapshot to a text file has locked all other text files under modification.
(I am French -Translation made by Reverso)

Salut LisiLu. Fais Alt+0 (Alt+zéro)
Le pourquoi est déjà plus haut dans la thread. :wink: Mais en bref, tu es présentement en mode révision. Tu as dû faire le raccourci clavier pour, par accident.


Si tu as du texte viré rouge à remettre à sa couleur normale après ça, sélectionne-le, et :

. . . . . . . .
Just do Alt+0.
(The explanation is already in this thread, earlier posts.)
—French explanation to accommodate—

Merci. Super çà a résolu le problème.

1 Like