Text colors for POV

To prevent my tendency to headhop, I use a different color of text for each POV character as I draft. I have style set for each. However, if I’m writing a scene from, for example, Green’s perspective and hit return, text color reverts to black. Are formats not the proper tool to accomplish what I want? Is there any way to keep new paragraphs in the color of the previous one until I’m ready for a POV change at a scene break?


In the config of your style, set the next style to be itself.


You need to set the “Next Style:” dropdown for each of your POV styles to the same style. Put your cursor in a suitable paragraph and choose Format > Style > Redefine Style from Selection.

A further suggestion, think about making your POV-styles character styles rather than paragraph styles, as removing colour on compile is a simple tick-box, whereas paragraph styles will make sorting it out much more hassle, as basically all “normal/body” paragraphs should be “No Style” in Scrivener.


Personally, I’d use the color from the box and wouldn’t play so much with font color.
This has the advantage that you don’t have to make your style include character attributes, which is otherwise in conflict with other formatting, and this in exchange for not much.

And – a different angle to @xiamenese’s advice – it’s less messing around at compile, too.

Actually, if you set it to “Save Character Attributes” and deselect “Include Font Family” and “Include Font Size”, all that is included in the style is the colour. So if you apply it to a stretch of “No Style” text, it becomes “No Style + character style”. Furthermore, you can:

  • set shortcuts, either from the set in the dialog, or, since @RLBuck is on a Mac, through System Settings > Keyboard (I don’t think setting shortcuts to the colours in the the box is possible, on the Mac at least);
  • when ready to compile, all you have to do is delete the styles and the colour attribute is removed at one fell swoop from the entire Draft/Manuscript wherever those particular style have been used…


But if I am not mistaken, it is an issue if you have bold or italic text, etc.

Away from computer as it’s time to sleep. I’ll look into that tomorrow. There may be differences between Mac and Windows on that.


Thanks, Mark! That’s what I was missing.

Yes, you can set style shortcuts in the dialog on Mac.

Yes, just tested; if you have any italics or bold in already existing text and you apply a colour character style, italics or bold will be overridden.

On the other hand, if you have text already styled with the colour, you can apply italics and bold without problem either as you type, or by selecting and applying them to the selection.

However, any other character style you may have created, “Emphasis” or “Strong” and in my case Chinese (unsurprisingly), will override any other character style like a colour. On the other hand, I can set text to type in Chinese and then colour it through the style.

Confused? Somewhat! So basically, style or colour-box comes to whichever suits your way of working best.


Further thoughts on this: actually the reasons are (comparatively) straightforward. Italics and bold, as applied by Cmd/Ctrl-I and Cmd/Ctrl-B or any menu equivalent are formatting not styles, as I imagine is colour from the colour-box.