Text colour of Normal Style

Once upon a time, I set my normal style to be dark blue. I’ve now changed that (General - Editing - Formatting AND Format - Redefine Style) to dark brown. I’ve made sure that the follow-on style from Normal is also Normal.

My problem is that the follow-on style (i.e. after pressing Return) is still dark blue. I change the whole paragraph (including the paragraph marker) to brown, I go through Format - Redefine Normal Style Based On Current again - and still when I create a new paragraph, the new text is back to blue.

Any help welcome. Thanks.

Overall, this is not the best way to make a cosmetic choice about how the text editor looks, if that is what this is about. Leave text colour off in your default settings, and instead use the Appearance: Main Editor: Colors: Text setting. You can also change Composition Mode’s text colour, if you want a different look there.

  1. Select a paragraph and right-click on the selection.
  2. Use the Text Color submenu to “Remove color”.
  3. Use the Format ▸ Make Formatting Default menu command.

Trying to use literal formatting for this can make everything awkward (as you’ve found). It means you can’t use colour at all when you compile, because you’ll always have to strip it all out. Tools that reset formatting may not always work the way you expect because text colour is, like italics, meant to be something preserved as a deliberate part of the text’s meaning.

(P.S. Using a “normal” style everywhere may also be making things more complicated and difficult than they need to be. Scrivener works better only using styles where things aren’t normal.)

1 Like

Thanks, that’s helpful.