Text documents (script vs free write)


Hope someone can help out with a minor issue regarding adding text documents / subdocuments.

I’m writing a screenplay, and have the normal ‘Scenes’ folder in the binder. I’ve also added a separate folder for the Treatment / Outline.

Usually, when I add a new document to the ‘Scenes’ folder, it will of course add a ‘Screenplay’ document - Yellow icon document called ‘New Scene’, containing the script format (Scene Heading / Action / Character / Etc).

Usually, when I add a new document to my ‘Treatment’ folder, it adds a ‘free write’ type text document - White icon document called ‘Untitled’, which does not have script format.

So far, so good.

The issue is that after adding a document to one folder, I add another document to the other folder, and it creates the wrong type of document.

For example, I would add a ‘free write’ document to the ‘Treatment’ folder. Afterwards, I add a document to the ‘Scenes’ folder, and it would also create a ‘free write’ type document too, instead of creating a ‘scene’ document containing the script format. This also happens vice versa.

The issue seems to occur mainly when trying to add a document with the folder itself highlighted / selected. If I highlight / select a specific document within the folder, which is of the correct type, than the new created document will also be of that type

  1. Is there a way to add a new text document, and manually choose whether it will be a ‘scene’ or ‘free write’ type document?

  2. When I go to ‘Documents > Default New Subdocument Type’, it only gives 3 options: Text / Character Sketch / Setting Sketch. It seems that Scrivener regards both the ‘scene’ and ‘free write’ type documents simply as ‘Text’ - Is there a way to differentiate between those 2 type of documents?

Mac OS X El Capitan 10.11.6 (but had the same issue with Yosemite)
Scrivener version 2.5 (25239)

Thanks in advance for people helping out. Sorry for the long lost.
Love this product by the way!

It sounds like the templates folder doesn’t contain the correct templates or the selection of default templates has gone awry. Forgive me if these questions are very basic, but it’s worth checking everything from the beginning.

  1. Do you have a designated template folder set? (i.e. it has a small T in the centre of the icon). There can only be one template folder in the binder – doesn’t matter what it’s called, but it must have the small T…)

  2. Does that template folder include templates for ‘New Scene’ and ‘New free text’ (whatever you’ve called them)? If not, then the first part of the problem is solved – templates must be in the designated templates folder to appear in the Project > New from Template menu. So create them if they don’t exist.

  3. Make sure the New Scene template is in Scriptwriting mode and the New free text template in Normal mode (cmd-8 toggle, of course).

Now test them. Go to a folder that is neither ‘Scenes’ nor ‘Treatment’ and create a new document of both types, explicitly using Project > New from Template > New Scene / New Free Text. The new documents should of course already be in their respective modes (Screenwriting / Normal).

If this works (I’ve just been followed it as I’m writing this and it does for me…), then at least we know the basic template system is working.

The last thing to check is the automatic creation of a specific type of document in a specific folder.

Click on the Scenes folder in the Binder, and then on Documents > Default New Sub-Document Type > New Scene. Repeat for the Treatment folder and of course choose New Free Text.

Now highlight the Scenes folder in the binder and press Ctl-N. It should create a New Scene with Scriptwriting mode activated. Test the Treatment folder in the same way, and check that the New Free Text has normal mode activated. BTW, when you’re in either of the folders, the first item of the Project menu will change to reflect the selected template (i.e. either New Scene template or New Normal template as appropriate).

Sorry for the basic approach, and apologies if it’s too basic, but if you’ve tried all this and it still doesn’t work, then I don’t know what’s wrong, because I’ve just recreated the steps and it works for me…


Thank you very much for taking the time to write a very detailed response!

I’d like to clarify that I am not trying to create custom templates, but rather, I am just trying to figure out if there is a way differentiate between 2 types of built in text documents - A Script format type document (with all the Scene Heading, Action, etc), and a standard text document.

Sometimes I go back and forth between the ‘scenes’ folder, which should contain script format text documents, and another folder, which should contain standard text documents, and when I add a new text document, I adds the wrong type (adds a standard text document to the ‘Scenes’ folder, or a script document to the ‘Treatment’ folder)

Either way, I had a kind of a workaround, and now with your kind assistance I have a better workaround - I added the default ‘scene’ document and a standard text document to the templates folder, and now I’m simply using them as default subdocuments for the appropriate folders (previously, the default new subdocument type for both folders was simply a ‘text’ document, which could add both a script document and a standard text document).

Thanks again!

Glad it helped.

Just to be precise though, a document isn’t so much a ‘scriptwriting’ or a ‘normal’ document. There are simply two ways at looking at every document: in Scriptwriting or Normal mode, and the document remembers which one was used to edit it last. You can see this by toggle cmd-8 on and off with any (non-pdf or image) document in the binder. You could start every single scene in your screenplay off in Normal mode and it wouldn’t matter — after all, it would only be a cmd-8 away from being right.

All turning on Scriptwriting mode does is to make available the special elements and formatting – if you turn it off, it won’t affect the formatting that’s already there, just any new text.

Where the templates are useful is that they allow you to enter boilerplate text or metadata (a label that only apply to Scenes, for example).

Thank you for another terrific response, this was exactly the information I was looking for.

I was not aware of the cmd-8 trick to toggle a document between scriptwriting mode and standard text mode, and thus was ‘stuck’ at certain times.

I also see now that under Format > Scriptwriting, the ‘Script mode / cmd-8’ function has a check mark to indicate it’s toggled, which I did not notice beforehand.

Issue resolved. Cheers!

Good – glad it helped!

Me neither! And that’s exactly the answer I came here to find.
So thanks again to @brookter!