Text Replace/With problem

I’ve always liked the fact that I can set up text substitutions in the Mac’s Keyboard preference panel, in the Text tab.

Two columns, one for Replace, one for With. So, for example, I often mistype you’ve as you;ve. Simply put you;ve in the Replace column and you’ve in the With column. Then the next time I type you;ve in one of Scriv projects, it’s more or less instantly changed to you’ve. And so on.

Recently, the entries I’ve set up in the Text tab will disappear, for no apparent reason. I started to reconstruct the entries as I stumbled on them. Now it’s getting really irritating, though. Almost as soon as I start to reconstruct the entries, next time I look, they’ve disappeared. (I did find that you can command-A the entries in the Text table and copy the lot to the desktop, making a file called Text Substitutions.plist, so at least I can keep a master copy.)

But there’s clearly something adrift with my Keyboard prefs panel, and specifically the Text tab. I do have my System Prefs as one of the items ticked in the iCloud Drive, as I like to keep things like those Text substitutions available when I work on my laptop. I’ve tried rebooting and so on, but nothing seems to fix the problem.

I’m using, with MacOS 10.12.3, on a Mac mini (main machine) and a MacBook Air laptop.

Anyone have any ideas?

That’s a neat trick with copying them to the desktop to make a backup.

I don’t know the answer to your question though, but since you mentioned using sync on the list you might as well try turning that off for a spell and see if the problem goes away without it. If it is causing issues, who knows what other settings you are losing in the background.

Have you tried posting to the Apple discussion boards as well? You might find someone who knows the matter here, but there are more people with Mac-specific know how wandering around in those forums helping people, than here.

Thanks AmberV. I will try your suggestion and remove the sync for now to see if it goes away.

I realise this isn’t a Scriv-specific question, but thought it worth seeing if anyone was having similar probs.

I did post on the Apple forum, and aside from some advice about deleting this or that folder associated with iCloud syncing, which I’ve tried without success so far, I drew a blank there.

I just wondered if anyone was experiencing anything at all similar. As far as I can recall, this seems to have been happening only since the 10.12.3 update.

Yeah, I’m having a similar problem system wide.

My substitutions aren’t disappearing, but failing to substitute or delaying substitution until a return character is typed.

I’m pretty sure this was after 10.12.3 update

I’m also having problems with Keyboard > Shortcuts > Services preferences erasing themselves following a change. :smiling_imp: com.apple.nsservicescache.plist and pbs.plist are part of the conspiracy.

Interesting, bobembry.

My problem does seem to have gone away for now, now that I’ve switched off iCloud Drive’s syncing for system prefs, after AmberV’s suggestion. Next time I switch to my laptop from my mini, I’ll have to manually send over the latest text substitutions file, which is a bit of a pain … and seems rather old hat, given what syncing is supposed to achieve.

I’ve looked around a bit more online and there do seem to be some general moans about recent probs with iCloud Drive syncing of this sort of thing.

Not sure what the nsservicescache file and so on that you mention are, bobembry, but presumably sync-related.

Anyway, fingers crossed something will be sorted for 10.12.4. Or 5. Or 6 …

I’ve now had a about a week with iCloud Drive syncing of System Prefs checked off, and my Text substitutions have remained in place, rock solid.

Certainly does look like that was the problem.

Bobembry, I’d still be interested to know why you singled out the nsservicescache file and so on. Are these also sync-related?

While I was still trying to make the syncing work, a reply I got about the problem at the Apple forum suggested deleting the folder ~/Library/Group Containers/com.apple.InputMethodKit.TextReplacementService on the two computers concerned. I did that, but no difference. But I now notice that there is an identically named folder in ~/Library/Containers, so I’m thinking it might be worth having a go at deleting those and syncing up again. Anyone had any experience with any of this?

My problem is related to Services shortcuts being spontaneously reset to some “default” configuration. This configuration is connected to Preference/pbs.plist which seems to be derived from nsservicescache. My problem started with 10.12.3. When I trash both pbs.plist and nsservicescache then restart, nsservicescache is rebuilt, but pbs.plist is missing. It seems to require editing Preference Pane > Keyboard > Shortcuts > Services before pbs.plist is created. I just noticed that nsservicescache was created and modified this morning at the same time, but pbs.plist has not been modified since Feb 6. About 30% of nsservicescache’s file size has evaporated since I first encountered my problem. I’m totally baffled and reluctant to change Preference Pane > Keyboard > Shortcuts > Services settings.