Text selected when inserting footnotes

When turning on footnote mode, text next to the cursor gets selected and converted to a footnote in certain scenarios. This seems to always happen when going into the middle of a block of text (e.g. at this point, putting the cursor just after the period of my first sentence in this post) and happens just when typing at the end of the document unless the footnote follows certain punctuation.

  1. Type a sentence in the Editor, ending with a period.
  2. Turn on footnote mode and type.

Everything is normal–no text was selected when switching to footnote mode. (This seems true following periods, commas, question marks, parentheses, square brackets, braces, semicolons, colons, exclamation marks, and hyphens.)

  1. Turn off footnote mode (there’s a bug here which will jump you back to the beginning of the footnote–copy some regular text and just paste it at the end of the footnote to get out of footnote mode) and write some more, no ending punctuation and leaving the cursor at the end of the word (no space).
  2. Turn on footnote mode.

The last word typed gets selected and converted to a footnote.

  1. Leave footnote mode and type a few more sentences, then go back to the end of one of those (not the final sentence) and turn on footnote mode again.

The final punctuation of the sentence gets selected and converted to a footnote. This happens even if you place the cursor after a space following the end of the sentence (which would be unnatural for a footnote anyway) up until the cursor is touching characters on the right, at which point the word to the right of the cursor gets selected instead. It also happens when there’s no punctuation at all; the whole word just gets selected.

Beta 1.9 on XP pro SP3