Text selection in scriveners mode

I’ve been having an issue with using the scriveners mode for my projects. When I try to select more than one line of text the cursor essentially races to the end of the section. It’s virtually impossible to select a few lines of text because the scrolling is so sensitive. I’m not sure if this is a bug or if there is something wrong with the way I have my documents set up.

This issue has been happening for a while, using both Win 7 and 8. At the moment the only way I can deal with it is to work on the individual document rather than using scriveners mode.

Any help would be much appreciated!

On a Mac, you can put the insertion point at one end of the text you want, hold down shift, scroll up or down to the other end of the text you want, and then click again before releasing the shift key. Useful if the cursor is slippery or if you need to grab a long scroll of text very quickly. Same in Windows?

I seem to remember reading a thread that the rich text editor provided by Qt — the Windows version is created using Qt — doesn’t allow selecting across file boundaries, which is what is happeninng. The same was true in version 1 of Mac Scrivener, I seem to remember, but Keith found a way to get round it in v. 2.

I believe LAP and Tiho are still trying to find a way round this limitation of the frameworks they are using.

In Scrivener, each document — whether folder or document as such — is a separate file on disk, as is transparent for any Windows user to see, while we Mac users have to open the package to see. Scrivenings merely makes it possible to view these files as a sequence under Windows.

Mr X

Thanks Briar for the tip. That certainly works the same way in Windows and I guess will do as a workaround.

Xiam, thanks too, though I’m actually just trying to select text within one document rather than across documents within the scrivenings. Unless I’ve misunderstood you I don’t think that’s the issue here.

The quick scrolling is a bug in the current Scrivenings mode when using Typewriter mode in the editor. Disabling that via Format > Options > Typewriter Mode should fix the problem.

Hi Jovan,

I should apologise. I misread your post while skimming through. Briar Kit Esme and MM’s posts are far more pertinent to your question.

Mr X