Text width and copy/pasted content

I’m new to scrivener, and I start to write a chapter using the default text document from scrivener (click foder, add new text document). The text didn’t fill the whole are, but word wrapped in a format that I liked.

In another folder, I did the same thing but copy/pasted some text I wrote in notepad.

Scrivener did not onl ignore its original format, assuming the text format from notepad, as it completely filled the text area, ignoring also the word wrap column.

So, my two questions are:

  1. Can I have scrivener configured to always ignore external text formats, chaning them, instead, to the format of a default scrivener text file?

  2. How can I make this unformatted text to respect again the original word wrap column? I can’t find that setting anywhere.

Thanks for your help

When copying and pasting, you can use Edit > Paste and Match Style (Ctrl+Shift+V) to paste as plain text, thereby stripping any formatting from the copied text and having it assume the formatting of the paragraph where it’s pasted.

That will strip everything, including character formatting like italics, so the alternative which gives you a bit more control is to use Documents > Convert > Formatting to Default Text Style on a document after a regular paste. This adjusts the formatting of the entire document to match the formatting set in the Editor tab of Tools > Options, i.e. the formatting of new documents created in Scrivener, and you also will get some options for refining the conversion. Character formatting is preserved.

For adjusting your current document, or for any documents you import (rather than copying and pasting), using Documents > Convert > Formatting to Default Text Style should get you what you want.

Thanks for your help.

(Ctrl+shift+v) worked like a charm.

On document adjustment, I just found what I was looking for.
I need to show the ruler and fix the display are to whatever I wanted.
As far I understood, it will only afect the writing text.
The final compiled doc won’t be affected by it, and that was exactly what I want.

Thanks again for your help