Themes

Hey,

played around with Themes and Dark mode recently. Thought hitting Scrivener>Theme>default would bring everything back to where it was. Is there any other quick way to get the default colors back? In my case the light Appearance which I changed to the purple theme changes back to the black Appearance after hitting default. Switching back to the Light Appearance after that, it is still showing the purple theme.

If I hit default when using Solarized Light for example, the Appearance switches to the Dark Appearance too, though the Editor (my sheet of paper) remains in those sandy color the whole Solarized light Theme comes with. I then have to manually set the Editor to a white piece of paper to be back to normal. Same goes for text highlighting.

To be fair, I was just playing around and won’t use Themes regularly.

Thanks.

Argh! I thought we got that bug fixed. It looks like the command works as expected (and yes, you’re right, it should simply reset those preferences related to Themes back to factory defaults, leaving all other prefs alone) so long as your Dark/Light appearance setting is coherent with the system. If the system is in Dark Mode but Scrivener is forced to Light, then using Defaults will reset your Appearance setting to “System”, and then factory default whatever you ended up in, rather than what you started with.

So the solution at the moment is to keep the System Preferences: General pane open, and with Scrivener set to Scrivener ▸ Appearance ▸ System. Switch to dark at the system level and reset to Defaults, then switch to light and repeat.

Well that could be expected if you have Scrivener ▸ Appearance ▸ Keep Main Editors Light.

Thanks for the quick reply even on a Sunday.

Nice, that did the trick.

This should then relate to the above bug too, right? I expect the editor to change to clear white, by hitting default, not to keep those sandy stuff.

I’m not sure I follow - I can’t reproduce a bug on my end. Here’s what I tried:

  1. Default settings, light mode.

  2. Switch to “Solarized Dark” - the app changes to a dark appearance with custom settings.

  3. Switch to “Default” theme - everything returns to normal; that is, the standard default settings for the current system appearance and the current system appearance is used.

Now, if I switch to Dark Mode via system settings, dark mode will still be using “Solarized Dark” until you reset the theme there, but that’s how it is intended to work. Hitting “Default” just takes you back to the default for the current mode. If it didn’t do this, it would have to reset two sets of preferences, both the dark and light settings. I suppose it could do that - “Default” could wipe and clear both light and dark mode settings and reset them to the default - but that seems a little odd to me, and in other circumstances it would be wiping settings “behind your back” when you might not want it to.

(I’m not sure why Ioa thinks this was a bug that was fixed as it was not something brought up during testing.)

Or am I missing something? Is the bug something different?

ECJ - if you have dark mode set up to use the light editor, then a dark theme will not affect the light editor settings; likewise resetting a dark theme will not affect light editor settings, and nor should it. Perhaps you can post step-by-step instructions showing the steps needed to see what you mean along with what you expect to happen?

All the best,
Keith

I`ll try my best:

Mojave Darkmode. Scrivener Darkmode. Regular default Theme, Dark with Light Editor as white as paper can be.

-Switching to Solarized Light > Scrivener changes to Light mode, Binder, Editor and Inspector all get this sandy color (I guess we can call that “beige” in english too). So far so good.
-From here switching back to the dark Appearance: Binder, Inspector and Menu Bar turn dark, the Editor though stays sandy-beige. Even if I chose Theme>Default, the Editor won’t change back to paper-like-white - stays sandy-beige. I can either change that back to paper-like-white in the Settings>Appearance>Light Editors (where I have to change the Text Selection color back to default too) or like Ioa said, changing system Settings before changing Scrivener to default.

Sorry for any confusion. Should have explained that better in first place.

What you did during your step-by-step trial is the exact opposite, going from Light, to dark via solarized Theme, back to light via default. This works flawlessly for me too.

This isn’t true for me too, I’m afraid:

If I am in Light mode (not System default to be clear) and have Solarized Light checked, then hit default (in Theme, not in System default in Appearance), Scrivener changes back to dark mode (keeps sandy-beige Editor) and the toggle in Appearance changes to System default automatically. Guess this shouldn’t happen as long as I am not using System default but Light Mode, right?

Additional note: Just updated my Macbook from Mojave 10.14 to 10.14.1 to see if what happens. Didn’t want to upgrade either Machine during NaNoWriMo acutally as Apple… well we all know Apple isn’t really Apple anymore in many cases, I guess. However that didn’t change anything.

Keith, I know you got other things to do but I would love to know if you could follow what I did with the Themes here.

Played around this a bit more on different machines recently, there must be something that is hindering the “default Theme functionality” to work as it is supposed to when Mojave is in Dark Mode. Works fine when in Bright Mode though. My question now is, if that is a bug in your code, Mojaves code or anything on my machines that plays error to this.

Again: Don’t get me wrong, no pressure here. I just don’t want to miss anything.

Hi ECJ,

Sorry, I’ve been preoccupied not only with the App Store bug and some bug fixes, but also with a house move, so things are a little chaotic. This should be addressed for the next update, though. What you are running into is expected behaviour in a way. If you have things set up to use light editors, then the main editors use the light theme while everything else uses the dark theme - that’s expected, and the point of using light editors. But I can see that this is a little confusing when resetting to the “Default” theme. I have therefore made it so that (1) choosing “Default” no longer resets the appearance and (2) if you are using light editors, it asks you if you would like to reset the light theme too. This allows you to return to a true default.

All the best,
Keith

Don’t worry. We all have chaotic days. Hope everything went well so far.

Thanks for fixing this.